Modify

Opened 3 years ago

Closed 3 years ago

#16768 closed defect (duplicate)

JOSM loses keyboard

Reported by: bhil@… Owned by: bhil@…
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

JOSM latest (14270, but also found in 14066)
The dialog for editing tags does suddenly no more respond to keyboard input. Tags can still be added using the mouse. Sometimes, the keyboard can be used after adding a tag with the mouse, but not always. If that fails, the keyboard does not work in the main window or other dialogs (e.g. upload dialog) either.
In rare occasions, also the mouse access gets lost.
Other applications on the machine can still be accessed by keyboard and mouse.

Windows 7 64bit, Java 8.0.121 (64 bit)
JOSM is started via a vb script:

Dim WshShell
Set WshShell = WScript.CreateObject("WScript.Shell")
WshShell.Run """C:\Program Files\Java\jre1.8.0_121\bin\java.exe"" -Xmx4G -jar ""C:\Program Files (x86)\OpenStreetMap\JOSM\josm-latest-14270.jar""", 0

The computer has 4 cores, and 8 GB RAM installed

Attachments (0)

Change History (8)

comment:1 Changed 3 years ago by Don-vip

Owner: changed from team to bhil@…
Status: newneedinfo

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.svg Report Bug.


comment:2 Changed 3 years ago by bhil@…

Status Report:

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-09-22 12:38:49 +0200 (Sat, 22 Sep 2018)
Build-Date:2018-09-23 01:32:38
Revision:14270
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14270 de) Windows 7 64-Bit
OS Build number: Windows 7 Enterprise (7601)
Memory Usage: 393 MB / 1820 MB (230 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768, \Display1 2560x1440
Maximum Screen Size: 2560x1440

Plugins:
+ turnrestrictions (34643)
+ undelete (34568)
+ utilsplugin2 (34506)

Tagging presets:
+ C:\ProgramData\Josm\Presets\SkiingTrail.xml
+ C:\ProgramData\Josm\Presets\<user.name>.xml

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

OSM API: http://api.openstreetmap.org/api

Expected behavior:
Keyboard and mouse can be used for editing data in edit dialogs or controlling the application

Actual behavior:
The expected behavior was found initially. After some armchair mapping, the keyboard was no more usable. In rare occasions, also the mouse access got lost.
Other applications on the machine could still be accessed by keyboard and mouse.

Reproducibility
There are no clear steps to follow in order to reproduce the defective behavior. It "just happens".
Changesets 62844711, 62845359, 62845919, 62848562 were created with defective versions (note that the behavior also exists in version 14066) and show different sizes, i.e. the defect showed up at different durations of mapping.
The defect was not found in version 11746 (changeset 62851285).

comment:3 Changed 3 years ago by Don-vip

You're using a very old version of Java. Please upgrade to latest version first (8u181).

comment:4 in reply to:  3 Changed 3 years ago by bhil@…

Replying to Don-vip:

You're using a very old version of Java. Please upgrade to latest version first (8u181).

The defective behavior does not occur with version 11746 of JOSM, hence the defect was introduced some when between versions 11477 and 14066.
Java Updates also mean that automatic updaters are installed - and I hate such enforced updates. I won't do that.

comment:5 Changed 3 years ago by stoecker

Resolution: irreproducible
Status: needinfoclosed

comment:6 Changed 3 years ago by anonymous

The problem does still exist in version 14663. It occurred after just 3 minutes of mapping.
Again downgrading to 11746, which proved stable for hours of mapping.

comment:7 Changed 3 years ago by anonymous

Resolution: irreproducible
Status: closedreopened

comment:8 Changed 3 years ago by stoecker

Resolution: duplicate
Status: reopenedclosed

Closed as duplicate of #13160.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bhil@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.