Modify

Opened 10 years ago

Closed 10 years ago

#1673 closed defect (wontfix)

Remapping keys in configuration have no effect

Reported by: bilbo Owned by: framm
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I have tried to remap keys cor copy from default Ctrl-C to Ctrl-Insert and for Paste from default Ctrl-V to Shift-Insert.

However, when I pressed OK, closed JOSM and started it again, the key went back to default

I peeked in the preferences file, but the part related to shortcuts is not very human readable for configuration by hand, so I am not sure what is happening there.

I tried even removing all keys beginning with "shortcut." in case the problem is with the configuration going into some "rotten" state, but that won't help at all - the problem keeps happening.

The relevant section of configuration file (with which the problem is happening) is following:

shortcut.groups.0=-1
shortcut.groups.1=128
shortcut.groups.10=64
shortcut.groups.11=576
shortcut.groups.12=64
shortcut.groups.13=512
shortcut.groups.14=-1
shortcut.groups.15=640
shortcut.groups.16=640
shortcut.groups.17=576
shortcut.groups.18=512
shortcut.groups.19=128
shortcut.groups.2=128
shortcut.groups.20=512
shortcut.groups.3=0
shortcut.groups.4=512
shortcut.groups.5=0
shortcut.groups.6=512
shortcut.groups.7=-1
shortcut.groups.8=192
shortcut.groups.9=192
shortcut.groups.configured=true
shortcut.shortcut.1=system:paste;Edit: Paste;86;1000;155;64;false;true
shortcut.shortcut.3=file:upload;File: Upload to OSM ...;85;8;85;192;false;true
shortcut.shortcut.4=system:pastestyle;Edit: Paste Tags;86;2;86;192;false;true
shortcut.shortcut.5=view:gpxlines;View: Toggle GPX Lines;88;2;88;192;false;true
shortcut.shortcut.6=Open OpenStreetBugs;Open OpenStreetBugs;79;2;79;192;false;true
shortcut.shortcut.7=auto:Simplify Way;Simplify Way;89;2;89;192;false;true

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by anonymous

Resolution: wontfix
Status: newclosed

keys with "system:" ids are bindings to the operating systems global shortcuts, and as such cannot be changed. (unless the used os does not have bindings for that action, in that case they can be changed, e.g. Preferences on Windows)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.