Modify

Opened 3 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#16699 closed defect (invalid)

Layer Streetside Crash

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin streetside Version:
Keywords: javafx Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-08-21 02:00:41 +0200 (Tue, 21 Aug 2018)
Build-Date:2018-08-21 01:33:03
Revision:14174
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14174 fr) Linux Mint 19 Tara
Memory Usage: 394 MB / 695 MB (203 MB allocated, but free)
Java version: 1.8.0_181-8u181-b13-0ubuntu0.18.04.1-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1024x768
Maximum Screen Size: 1024x768
Java package: openjdk-8-jre:amd64-8u181-b13-0ubuntu0.18.04.1
Dataset consistency test: No problems found

Plugins:
+ CustomizePublicTransportStop (34501)
+ ImageWayPoint (34206)
+ ImportImagePlugin (34576)
+ MicrosoftStreetside (34577)
+ PicLayer (34544)
+ apache-commons (34506)
+ apache-http (34506)
+ changeset-viewer (15)
+ dataimport (34575)
+ ejml (34389)
+ geojson (87)
+ geotools (34513)
+ gson (34389)
+ imagery_offset_db (34596)
+ jaxb (34506)
+ jna (34492)
+ jogl (1.2.1)
+ jts (34524)
+ log4j (34527)
+ photo_geotagging (34576)
+ public_transport (34548)
+ public_transport_layer (34549)
+ rasterfilters (34550)
+ undelete (34568)
+ utilsplugin2 (34506)
+ wikipedia (v1.1.0)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: org.openstreetmap.josm.plugins.PluginException: Une erreur est survenue dans le greffon MicrosoftStreetside. Cause : java.lang.reflect.InvocationTargetException. Cause : java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel. Cause : java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
- W: Avertissement - <html>JOSM ne parvient pas à trouver d’information sur les greffons suivants :<ul><li>apache-commons</li><li>geotools</li><li>dataimport</li><li>public_transport</li><li>jaxb</li><li>utilsplugin2</li><li>public_transport_layer</li><li>jogl</li><li>wikipedia</li><li>jna</li><li>rasterfilters</li><li>MicrosoftStreetside</li><li>PicLayer</li><li>log4j</li><li>CustomizePublicTransportStop</li><li>imagery_offset_db</li><li>jts</li><li>changeset-viewer</li><li>ejml</li><li>ImageWayPoint</li><li>geojson</li><li>photo_geotagging</li><li>ImportImagePlugin</li><li>undelete</li><li>gson</li><li>apache-http</li></ul>Les greffons ne seront pas chargés.</html>
- E: Connexion au proxy '/127.0.0.1:9150' pour lʼURI 'https://josm.openstreetmap.de/wiki/ImageFilters' impossible. Lʼexception était: java.net.SocketTimeoutException: Connect timed out
- E: java.net.SocketTimeoutException: Read timed out
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel. Cause : java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
- W: Avertissement - <html>JOSM ne parvient pas à trouver d’information sur les greffons suivants :<ul><li>apache-commons</li><li>geotools</li><li>dataimport</li><li>public_transport</li><li>jaxb</li><li>utilsplugin2</li><li>public_transport_layer</li><li>jogl</li><li>wikipedia</li><li>jna</li><li>rasterfilters</li><li>MicrosoftStreetside</li><li>PicLayer</li><li>log4j</li><li>CustomizePublicTransportStop</li><li>imagery_offset_db</li><li>jts</li><li>changeset-viewer</li><li>ejml</li><li>ImageWayPoint</li><li>geojson</li><li>photo_geotagging</li><li>ImportImagePlugin</li><li>undelete</li><li>gson</li><li>apache-http</li></ul>Les greffons ne seront pas chargés.</html>
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel. Cause : java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel. Cause : java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
- W: Avertissement - <html>JOSM ne parvient pas à trouver d’information sur les greffons suivants :<ul><li>apache-commons</li><li>geotools</li><li>dataimport</li><li>public_transport</li><li>jaxb</li><li>utilsplugin2</li><li>public_transport_layer</li><li>jogl</li><li>wikipedia</li><li>jna</li><li>rasterfilters</li><li>MicrosoftStreetside</li><li>PicLayer</li><li>log4j</li><li>CustomizePublicTransportStop</li><li>imagery_offset_db</li><li>jts</li><li>changeset-viewer</li><li>ejml</li><li>ImageWayPoint</li><li>geojson</li><li>photo_geotagging</li><li>ImportImagePlugin</li><li>undelete</li><li>gson</li><li>apache-http</li></ul>Les greffons ne seront pas chargés.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (17) of main
java.lang.NoClassDefFoundError: javafx/embed/swing/JFXPanel
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:74)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at org.openstreetmap.josm.plugins.streetside.gui.StreetsideViewerDialog.<init>(StreetsideViewerDialog.java:35)
	at org.openstreetmap.josm.plugins.streetside.gui.StreetsideViewerDialog.getInstance(StreetsideViewerDialog.java:46)
	at org.openstreetmap.josm.plugins.streetside.StreetsideData.<init>(StreetsideData.java:65)
	at org.openstreetmap.josm.plugins.streetside.StreetsideLayer.<init>(StreetsideLayer.java:93)
	at org.openstreetmap.josm.plugins.streetside.StreetsideLayer.getInstance(StreetsideLayer.java:167)
	at org.openstreetmap.josm.plugins.streetside.actions.StreetsideDownloadAction.actionPerformed(StreetsideDownloadAction.java:52)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:842)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:886)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6539)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6304)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4535)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4476)
	at java.awt.Container.dispatchEventImpl(Container.java:2283)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at org.GNOME.Accessibility.AtkWrapper$6.dispatchEvent(AtkWrapper.java:715)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.ClassNotFoundException: javafx.embed.swing.JFXPanel
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:74)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 58 more

Attachments (0)

Change History (5)

comment:1 Changed 3 weeks ago by Don-vip

Component: CorePlugin streetside

comment:2 Changed 3 weeks ago by anonymous

Component: Plugin streetsideCore
Keywords: Plugin streetside added; template_report removed

comment:3 Changed 3 weeks ago by Don-vip

Component: CorePlugin streetside
Keywords: javafx added; Plugin streetside removed
Resolution: invalid
Status: newclosed

Plugin streetside requires JavaFX. Please install openjfx package.

comment:4 Changed 3 weeks ago by anonymous

Thank to add this information on detail of plugins

comment:5 Changed 3 weeks ago by Don-vip

It will be displayed in next version of the plugin, see #16682 and [o34606]

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.