Modify

Opened 14 years ago

Closed 13 years ago

#1665 closed enhancement (duplicate)

Loading MOTD delays JOSM start

Reported by: jpstotz Owned by: framm
Priority: minor Milestone:
Component: unspecified Version:
Keywords: MOTD startup delay Cc:

Description

The content of the GettingStarted panel (better known as "Message of the day" MOTD) is loaded on every start-up from josm.openstreetmap.de. Loading of the content is done synchronously meaning that the JOSM startup stops until the content has been loaded and parsed (depending on the network connection this takes several seconds).

This is IMHO an unnecessary delay in the JOSM start-up process.
The content should be cached and updated asynchronously on first start-up every day.

Attachments (0)

Change History (2)

comment:1 Changed 14 years ago by jpstotz

Addendum: I made some benchmarking tests of the relevant section. The result is that loading the content is not he only problem regarding the load delay. After loading two complex regular expressions are used for parsing the downloaded content as well as several modifications. On my 2 year old system this takes longer than downloading the content itself.

BTW: The overall MOTD system makes my stomach ache - on every start-up JOSM loads external content from a Wiki that is AFAIR write enabled for everyone (or should I say every attacker/bot?)! IMHO the MOTD content should be moved to a better protected place - may be to the SVN?

comment:2 Changed 13 years ago by stoecker

Resolution: duplicate
Status: newclosed

Duplicate of #1910.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.