Modify

#16588 closed defect (fixed)

ClassNotFoundException: javax.xml.bind.DatatypeConverter

Reported by: pauladriannem@… Owned by: bastiK
Priority: normal Milestone:
Component: Plugin native_password_manager Version: latest
Keywords: template_report java9 java11 jaxb Cc:

Description

What steps will reproduce the problem?

  1. Expert Mode is enabled
  2. Under Preferences, most plug-ins are enabled
  3. Upon restart for the changes to be effective, an unexpected bug has occurred

What is the expected result?

JOSM must restart normally, even after the plug-in switch/updates

What happens instead?

An error message has appeared after the restart.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-07-29 00:41:59 +0200 (Sun, 29 Jul 2018)
Revision:14066
Build-Date:2018-07-29 01:32:17
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14066 en) Windows 10 64-Bit
OS Build number: Windows 10 Home Single Language 1803 (17713)
Memory Usage: 256 MB / 2048 MB (141 MB allocated, but free)
Java version: 10.0.2+13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Plugins:
+ BuildingGeneralization (23)
+ ColorPlugin (1511895663)
+ CustomizePublicTransportStop (34206)
+ ElevationProfile (34389)
+ ImproveWay (1529701520)
+ Mapillary (v1.5.15)
+ MicrosoftStreetside (34389)
+ OpenStreetCam (155)
+ OpeningHoursEditor (34389)
+ RoadSigns (34109)
+ TombPlugin (55)
+ alignways (34389)
+ apache-commons (34389)
+ apache-http (34389)
+ areaselector (1529684353)
+ austriaaddresshelper (1525848529)
+ auto_tools (1529260859)
+ buildings_tools (34212)
+ changeset-viewer (15)
+ continuosDownload (1530471163)
+ ejml (34389)
+ imagery_offset_db (34370)
+ indoor_sweepline (34389)
+ indoorhelper (34389)
+ jna (34389)
+ livegps (34206)
+ log4j (34038)
+ merge-overlap (34389)
+ michigan_left (34206)
+ native_password_manager (34206)
+ print (34206)
+ public_transport (34265)
+ public_transport_layer (34280)
+ reverter (34271)
+ rex (1529698495)
+ routing (34187)
+ surveyor (34109)
+ tageditor (34109)
+ terracer (34109)
+ turnlanes (34288)
+ turnlanes-tagging (263)
+ turnrestrictions (34129)
+ undelete (34274)
+ utilsplugin2 (34389)
+ wikipedia (v1.0.2)

Map paint styles:
+ <josm.pref>\styles\sit.mapcss

Validator rules:
+ <josm.pref>\validator\indoorhelper.validator.mapcss

Last errors/warnings:
- E: java.util.concurrent.ExecutionException: [powershell, -Command, [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12;[System.Net.WebRequest]::Create('https://roottest-g2.pkioverheid.nl').GetResponse()]
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin routes. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.NoClassDefFoundError: javax/xml/bind/JAXBContext. Cause: java.lang.ClassNotFoundException: javax.xml.bind.JAXBContext
- W: Disable plugin - Could not load plugin 'routes'. Delete from preferences?
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter. Cause: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>ImproveWay</li><li>livegps</li><li>apache-commons</li><li>tageditor</li><li>RoadSigns</li><li>public_transport</li><li>alignways</li><li>OpenStreetCam</li><li>continuosDownload</li><li>routing</li><li>turnlanes-tagging</li><li>utilsplugin2</li><li>public_transport_layer</li><li>indoor_sweepline</li><li>terracer</li><li>turnrestrictions</li><li>wikipedia</li><li>jna</li><li>MicrosoftStreetside</li><li>log4j</li><li>CustomizePublicTransportStop</li><li>indoorhelper</li><li>BuildingGeneralization</li><li>auto_tools</li><li>imagery_offset_db</li><li>rex</li><li>ElevationProfile</li><li>Mapillary</li><li>changeset-viewer</li><li>surveyor</li><li>ejml</li><li>turnlanes</li><li>michigan_left</li><li>reverter</li><li>ColorPlugin</li><li>print</li><li>native_password_manager</li><li>TombPlugin</li><li>OpeningHoursEditor</li><li>areaselector</li><li>undelete</li><li>buildings_tools</li><li>austriaaddresshelper</li><li>apache-http</li><li>merge-overlap</li></ul>The plugins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (21) of main
java.lang.NoClassDefFoundError: javax/xml/bind/DatatypeConverter
	at org.openstreetmap.josm.plugins.npm.Win32Provider$JOSMPreferences.putByteArray(Win32Provider.java:20)
	at org.netbeans.modules.keyring.fallback.FallbackProvider._save(FallbackProvider.java:122)
	at org.netbeans.modules.keyring.fallback.FallbackProvider.testSampleKey(FallbackProvider.java:92)
	at org.netbeans.modules.keyring.fallback.FallbackProvider.enabled(FallbackProvider.java:79)
	at org.openstreetmap.josm.plugins.npm.InitializationWizard.detectNativePasswordManager(InitializationWizard.java:415)
	at org.openstreetmap.josm.plugins.npm.InitializationWizard.<init>(InitializationWizard.java:71)
	at org.openstreetmap.josm.plugins.npm.NPMPlugin$1.run(NPMPlugin.java:34)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.EventQueue.access$600(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.DatatypeConverter
	at java.base/java.net.URLClassLoader.findClass(Unknown Source)
	at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:74)
	at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
	... 21 more

=== RUNNING THREADS ===
Thread: AWT-Windows (19) of system
java.desktop@10.0.2/sun.awt.windows.WToolkit.eventLoop(Native Method)
java.desktop@10.0.2/sun.awt.windows.WToolkit.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Java2D Disposer (16) of system
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.base@10.0.2/java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.desktop@10.0.2/sun.java2d.Disposer.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Timer-0 (36) of main
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.lang.Object.wait(Unknown Source)
java.base@10.0.2/java.util.TimerThread.mainLoop(Unknown Source)
java.base@10.0.2/java.util.TimerThread.run(Unknown Source)

Thread: AWT-EventQueue-0 (21) of main
Stacktrace see above.

Thread: Reference Handler (2) of system
java.base@10.0.2/java.lang.ref.Reference.waitForReferencePendingList(Native Method)
java.base@10.0.2/java.lang.ref.Reference.processPendingReferences(Unknown Source)
java.base@10.0.2/java.lang.ref.Reference.access$000(Unknown Source)
java.base@10.0.2/java.lang.ref.Reference$ReferenceHandler.run(Unknown Source)

Thread: JCS-ElementEventQueue-Thread-1 (33) of main
java.base@10.0.2/jdk.internal.misc.Unsafe.park(Native Method)
java.base@10.0.2/java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.base@10.0.2/java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.base@10.0.2/java.util.concurrent.LinkedBlockingQueue.take(Unknown Source)
java.base@10.0.2/java.util.concurrent.ThreadPoolExecutor.getTask(Unknown Source)
java.base@10.0.2/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
java.base@10.0.2/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Finalizer (3) of system
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.base@10.0.2/java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.base@10.0.2/java.lang.ref.Finalizer$FinalizerThread.run(Unknown Source)

Thread: File Watcher (14) of main
java.base@10.0.2/jdk.internal.misc.Unsafe.park(Native Method)
java.base@10.0.2/java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.base@10.0.2/java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.base@10.0.2/java.util.concurrent.LinkedBlockingDeque.takeFirst(Unknown Source)
java.base@10.0.2/java.util.concurrent.LinkedBlockingDeque.take(Unknown Source)
java.base@10.0.2/sun.nio.fs.AbstractWatchService.take(Unknown Source)
app//org.openstreetmap.josm.io.FileWatcher.processEvents(FileWatcher.java:107)
app//org.openstreetmap.josm.io.FileWatcher$$Lambda$33/1151593579.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Attach Listener (5) of system

Thread: TimerQueue (23) of system
java.base@10.0.2/jdk.internal.misc.Unsafe.park(Native Method)
java.base@10.0.2/java.util.concurrent.locks.LockSupport.park(Unknown Source)
java.base@10.0.2/java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(Unknown Source)
java.base@10.0.2/java.util.concurrent.DelayQueue.take(Unknown Source)
java.desktop@10.0.2/javax.swing.TimerQueue.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Weak reference cleaner (26) of main
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.base@10.0.2/java.lang.ref.ReferenceQueue.remove(Unknown Source)
app//org.openstreetmap.josm.tools.ListenableWeakReference.clean(ListenableWeakReference.java:60)
app//org.openstreetmap.josm.tools.ListenableWeakReference$$Lambda$336/80756779.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Common-Cleaner (11) of InnocuousThreadGroup
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.lang.ref.ReferenceQueue.remove(Unknown Source)
java.base@10.0.2/jdk.internal.ref.CleanerImpl.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)
java.base@10.0.2/jdk.internal.misc.InnocuousThread.run(Unknown Source)

Thread: AWT-Shutdown (22) of system
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.lang.Object.wait(Unknown Source)
java.desktop@10.0.2/sun.awt.AWTAutoShutdown.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Timer-1 (39) of main
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.util.TimerThread.mainLoop(Unknown Source)
java.base@10.0.2/java.util.TimerThread.run(Unknown Source)

Thread: FileSystemWatchService (13) of main
java.base@10.0.2/sun.nio.fs.WindowsNativeDispatcher.GetQueuedCompletionStatus0(Native Method)
java.base@10.0.2/sun.nio.fs.WindowsNativeDispatcher.GetQueuedCompletionStatus(Unknown Source)
java.base@10.0.2/sun.nio.fs.WindowsWatchService$Poller.run(Unknown Source)
java.base@10.0.2/java.lang.Thread.run(Unknown Source)

Thread: Signal Dispatcher (4) of system

Thread: main (1)
java.base@10.0.2/java.lang.Object.wait(Native Method)
java.base@10.0.2/java.lang.Object.wait(Unknown Source)
java.desktop@10.0.2/java.awt.EventQueue.invokeAndWait(Unknown Source)
java.desktop@10.0.2/java.awt.EventQueue.invokeAndWait(Unknown Source)
java.desktop@10.0.2/javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
app//org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWait(GuiHelper.java:219)
app//org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:1298)
app//org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1074)
app//org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:283)
app//org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:864)

Attachments (0)

Change History (3)

comment:1 Changed 10 months ago by Don-vip

Component: CorePlugin native_password_manager
Milestone: 18.12
Owner: changed from team to bastiK
Summary: Unexpected error in JOSM 14066ClassNotFoundException: javax.xml.bind.DatatypeConverter

comment:2 Changed 10 months ago by Don-vip

Keywords: java9 java11 jaxb added

JAXB is harder to locate in Java 9, and is gone completely in Java 11. The plugin must be updated.

comment:3 Changed 10 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o34447:34448].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.