Modify

#16537 closed enhancement (duplicate)

The Overpass query wizard should recurse up

Reported by: Penegal Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: overpass recursion up wizard default Cc: tyr_asd

Description

Hello, there.

Wandering in OSM data I recently changed, I noticed that I broke some relations. I use the Overpass query wizard to retrieve only the type of ways I currently contribute to, but the wizard produces a query without a recurse up (<;); this makes jOSM not retrieving the relations in which the downloaded ways appear.

Consequently, when I divide a way, jOSM have no chance to handle the division of ways included in a relation - by keeping, as usual, the new way created by the division in the relation - as it simply doesn't know this way was in a relation. If I don't manually take care of retrieving the relations the ways are included into, jOSM happily lets me damage relations, not being aware of their existence. That could easily be prevented by having the wizard creating an Overpass query recursing up:

  1. automatically, without a specific user request, or
  2. upon a specific token, like … with relations or … up.

Now I know this behavior exists, I'll take care of circumventing it, but Overpass newbies could miss it, and inadvertently damage OSM relations by naively trusting the wizard knows what data to retrieve. The suggested change should take care of this loophole.

Regards.

Attachments (0)

Change History (2)

comment:1 Changed 19 months ago by simon04

Cc: tyr_asd added

Currently we call https://github.com/tyrasd/overpass-wizard and use its output directly without applying any transformations. I'm not sure whether the recurse up would be better applied in JOSM or in overpass-wizard? @tyr_asd, any thoughts?

comment:2 Changed 19 months ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12303.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.