Modify

Opened 2 months ago

Closed 2 months ago

Last modified 7 weeks ago

#16499 closed enhancement (fixed)

Support GDPR-compliant OSM extracts

Reported by: chenzero@… Owned by: team
Priority: normal Milestone: 18.07
Component: Core Version: tested
Keywords: template_report changeset geofabrik gdpr Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

Hello,
First, I would very appreciated that create this great software !

I downloaded a osm file from:
http://download.geofabrik.de/asia/china-latest.osm.bz2
however, when I tried to open it, JOSM reported:
Illegal value for attribute 'changeset'. Got 0. (at line 4, column 115). 327 bytes have been read

I traced into the code, it's fired in:
OsmReader.java function: readCommon() line: 587

            if (current.getChangesetId() <= 0) {
                if (current.isNew()) {
                    // for a new primitive we just log a warning
                    Logging.info(tr("Illegal value for attribute ''changeset'' on new object {1}. Got {0}. Resetting to 0.",
                            v, current.getUniqueId()));
                    current.setChangesetId(0);
                }
                else {
                    // for an existing primitive this is a problem
                    // ************   THIS LINE throw Exception *************
                    throwException(tr("Illegal value for attribute ''changeset''. Got {0}.", v));
                }
            }

few line of that file: china-latest.osm

<?xml version='1.0' encoding='UTF-8'?>
<osm version="0.6" generator="osmconvert 0.8.5" timestamp="2018-07-02T20:00:02Z">
        <bounds minlat="14.27437" minlon="73.41788" maxlat="53.65559" maxlon="134.8558999"/>
        <node id="274901" lat="22.3460512" lon="114.1811521" version="7" timestamp="2014-01-08T15:00:31Z" changeset="0"/>

Whether changeset can be 0 for a existing node ?
Thanks !

What is the expected result?

open successful

What happens instead?

Exception thrown

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-07-09 01:47:59 +0200 (Mon, 09 Jul 2018)
Build-Date:2018-07-08 23:50:14
Revision:14026
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14026 en) Linux Ubuntu 16.04.4 LTS
Memory Usage: 482 MB / 3330 MB (250 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Program arguments: [china-latest.osm]

Plugins:
+ DirectUpload (34389)
+ buildings_tools (34212)
+ fieldpapers (v0.4.3)
+ imagery_offset_db (34370)
+ print (34206)
+ utilsplugin2 (34389)

Last errors/warnings:
- W: Cannot lock cache directory. Will not use disk cache
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: org.openstreetmap.josm.io.IllegalDataException: Illegal value for attribute 'changeset'. Got 0. (at line 4, column 115). 327 bytes have been read. Cause: org.openstreetmap.josm.io.XmlStreamParsingException: Illegal value for attribute 'changeset'. Got 0. (at line 4, column 115). 327 bytes have been read
- E: Error - <html>Could not read file 'china-latest.osm'.<br>Error is:<br>Illegal value for attribute 'changeset'. Got 0. (at line 4, column 115). 327 bytes have been read</html>

Attachments (0)

Change History (7)

comment:1 Changed 2 months ago by Don-vip

Keywords: changeset added

comment:2 Changed 2 months ago by Don-vip

Description: modified (diff)

comment:3 Changed 2 months ago by Don-vip

Keywords: geofabrik gdpr added
Milestone: 18.07
Summary: OSM file open failedSupport GDPR-compliant OSM extracts
Type: defectenhancement

Quote from GeoFabrik:

The OpenStreetMap data files provided on this server do not contain the user names, user IDs and changeset IDs of the OSM objects. These metadata fields contain personal information about the OpenStreetMap contributors and are subject to data protection regulations in the European Union. Please note that these regulations apply even to processing that happens outside the European Union because some OpenStreetMap contributors live in the European Union.

We need to be able to open these files.

Extracts with full metadata are available to OpenStreetMap contributors only.

@chenzero: you should download your file here instead: https://osm-internal.download.geofabrik.de/

comment:4 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14038/josm:

fix #16499 - Support GDPR-compliant OSM extracts

comment:5 Changed 2 months ago by anonymous

Thanks!
After download that internal PBF file, I used following command to extract a city data,
osmosis --read-pbf china-latest-internal.osm.pbf --bounding-polygon file="/city1.poly" --write-xml city1.osm
and successfully open in the JOSM!
Cheers and Regards!

comment:6 Changed 7 weeks ago by aceman

Thanks.

There are multiple mistyped GPDR occurences in the changeset instead of GDPR.

comment:7 Changed 7 weeks ago by stoecker

In 14078/josm:

see #16499 - fix typos

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.