Modify

Opened 8 months ago

Closed 7 months ago

#16464 closed enhancement (fixed)

Complain about internet_access:fee combined with internet_access=no

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.07
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Add internet_access=no and internet_access:fee=no tags to an object
  2. Run validator

What is the expected result?

Validator complains about tagging price of nonexisting intenet.

What happens instead?

Nothing

Please provide any additional information below. Attach a screenshot if possible.

Overpass query:

[out:xml][timeout:2500][bbox:{{bbox}}];
(
  node["internet_access"="no"]["internet_access:fee"];
  way["internet_access"="no"]["internet_access:fee"];
  relation["internet_access"="no"]["internet_access:fee"];
);
(._;>;);
out meta;
URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-07-01 23:07:04 +0200 (Sun, 01 Jul 2018)
Build-Date:2018-07-01 21:10:23
Revision:13996
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13996 en) Linux Ubuntu 16.04.4 LTS
Memory Usage: 447 MB / 869 MB (122 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34389)
+ buildings_tools (34212)
+ continuosDownload (1530471163)
+ imagery_offset_db (34370)
+ reverter (34271)
+ todo (30305)

Last errors/warnings:
- W: javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake. Cause: java.io.EOFException: SSL peer shut down incorrectly
- W: javax.net.ssl.SSLHandshakeException: Remote host closed connection during handshake. Cause: java.io.EOFException: SSL peer shut down incorrectly
- E: Error header: Version mismatch: Provided 10, server had: 11 of Relation 6674601
- E: Conflicts detected - <html>Uploading <strong>failed</strong> because the server has a newer version of one<br>of your nodes, ways, or relations.<br>The conflict is caused by the <strong>relation</strong> with id <strong>6,674,601</strong>,<br>the server has version 11, your version is 10.<br><br>Click <strong>Synchronize relation 6,674,601 only</strong> to synchronize the conflicting primitive only.<br>Click <strong>Synchronize entire dataset</strong> to synchronize the entire local dataset with the server.<br>Click <strong>Cancel</strong> to abort and continue editing.<br></html>
- E: Error header: Version mismatch: Provided 2, server had: 3 of Relation 6692545
- E: Conflicts detected - <html>Uploading <strong>failed</strong> because the server has a newer version of one<br>of your nodes, ways, or relations.<br>The conflict is caused by the <strong>relation</strong> with id <strong>6,692,545</strong>,<br>the server has version 3, your version is 2.<br><br>Click <strong>Synchronize relation 6,692,545 only</strong> to synchronize the conflicting primitive only.<br>Click <strong>Synchronize entire dataset</strong> to synchronize the entire local dataset with the server.<br>Click <strong>Cancel</strong> to abort and continue editing.<br></html>
- W: java.net.SocketTimeoutException: Read timed out
- E: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out
- E: IO Exception - <html>Failed to upload data to or download data from<br>'https://overpass-api.de/api/interpreter'<br>due to a problem with transferring data.<br>Details (untranslated): Read timed out</html>

Attachments (0)

Change History (2)

comment:1 Changed 8 months ago by Klumbumbus

Milestone: 18.07

comment:2 Changed 7 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 14042/josm:

fix #16464 - warn about internet_access=no together with internet_access:fee

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.