Modify

Opened 5 months ago

Closed 5 months ago

#16446 closed defect (duplicate)

Don't show useless warning about unfullfilled plugin dependencies at startup

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Run JOSM and watch it starting up.

What is the expected result?

If JOSM detects that a certain plugin requires a yet unreleased JOSM version then stay quite until the dependency is fulfilled and update the plugin then. A user friendly software should solve its own problems itself without making noise.

What happens instead?

At startup JOSM complains that some plugins require a newer JOSM version than installed.
For instance: current JOSM version is 13.878, the plugin continuousDownload requires version 13.927 and pt_assistant requires version 13.957.
JOSM tells its user every single missing dependency in a separate dialog and finally in a summary dialog. However, neither updating the plugin makes sense because of the missing dependency (JOSM is updated onyl once a month) nor skipping them because this won't solve anything. As JOSM is updated once in a month this means the user has to confirm many pointless messages for up to a month.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-31 00:51:20 +0200 (Thu, 31 May 2018)
Build-Date:2018-05-30 22:58:01
Revision:13878
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13878 de) Mac OS X 10.11.6
OS Build number: Mac OS X 10.11.6 (15G21013)
Memory Usage: 1253 MB / 3641 MB (747 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 235005808 1280x1024, Display 1892189377 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djava.security.policy=file:<java.home>/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>/bin, -Djava.security.manager, -Djnlpx.origFilenameArg=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/56/1ee8cfb8-4c7bc0ae, -Djnlpx.remove=false, -Dsun.awt.warmup=true, -Djava.util.Arrays.useLegacyMergeSort=true, -Dmacosx.jnlpx.dock.name=JOSM, -Dmacosx.jnlpx.dock.icon=${HOME}/Library/Application Support/Oracle/Java/Deployment/cache/6.0/16/47ee53d0-451327f0.icns, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp , -Djnlpx.jvm="<java.home>/bin/java"]
Dataset consistency test: No problems found

Plugins:
+ FastDraw (34109)
+ FixAddresses (34109)
+ HouseNumberTaggingTool (34109)
+ Mapillary (v1.5.14+post13733)
+ OpenStreetCam (147)
+ PicLayer (34170)
+ RoadSigns (34109)
+ apache-commons (34109)
+ apache-http (34109)
+ buildings_tools (34212)
+ continuosDownload (68)
+ editgpx (34109)
+ ejml (34126)
+ ext_tools (34109)
+ geotools (34125)
+ gson (34038)
+ jts (34038)
+ log4j (34038)
+ measurement (34109)
+ photoadjust (34109)
+ print (34109)
+ pt_assistant
+ public_transport (34166)
+ reverter (34109)
+ splinex (34109)
+ tag2link (34109)
+ tageditor (34109)
+ terracer (34109)
+ turnlanes-tagging (263)
+ undelete (34109)
+ utilsplugin2 (34263)
+ wikipedia (v1.0.1)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ ${HOME}/Documents/ADFC-JOSM-Vorlage.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Postcode&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'presets/cycleway.png'
- W:  Selbständige Rad- / Fußwege: Could not get presets icon presets/cycleway.png
- E: Fehler beim Laden des Bildes 'presets/cycleway.png'
- W:  Radweg: Could not get presets icon presets/cycleway.png
- E: Fehler beim Laden des Bildes 'presets/footway.png'
- W:  Fußweg: Could not get presets icon presets/footway.png
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Achtung - <html>Die Erweiterung pt_assistant erfordert JOSM Version 13957. Die aktuelle JOSM-Version ist 13878.<br>Um diese Erweiterung verwenden zu können, muss JOSM aktualisiert werden.</html>
- W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/tools.cfg
- W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/repo.cfg

Attachments (0)

Change History (2)

comment:1 Changed 5 months ago by anonymous

Summary: Don't show useless warning a unfullfilled plugin dependencies at startupDon't show useless warning about unfullfilled plugin dependencies at startup

comment:2 Changed 5 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #16400.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.