Modify

#16383 closed defect (duplicate)

IllegalStateException with Reverter plugin

Reported by: hjart Owned by: Upliner
Priority: critical Milestone:
Component: Plugin reverter Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Try to use the reverter with https://www.openstreetmap.org/changeset/59777664

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-06-11 22:02:25 +0200 (Mon, 11 Jun 2018)
Revision:13922
Build-Date:2018-06-11 20:09:26
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13922 da) Linux openSUSE Leap 15.0
Memory Usage: 1164 MB / 1486 MB (63 MB allocated, but free)
Java version: 10.0.1+10-suse-lp150.1.11-x8664, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
Java package: java-10-openjdk:x86_64-10.0.1.0
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (34109)
+ InfoMode (34038)
+ Mapillary (v1.5.14+post13733)
+ OpeningHoursEditor (34095)
+ SimplifyArea (34109)
+ apache-commons (34109)
+ apache-http (34109)
+ buildings_tools (34212)
+ measurement (34109)
+ photo_geotagging (34109)
+ photoadjust (34109)
+ rasterfilters (34109)
+ reverter (34271)
+ todo (30304)
+ undelete (34274)
+ utilsplugin2 (34263)
+ wikipedia (v1.0.1)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ ${HOME}/Dokumenter/HjartsPresets.xml
+ ${HOME}/Dokumenter/DanishChainsPresets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DK.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Trees&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- E: Handled by bug report queue: java.lang.IllegalStateException: Manglende sammenlægningsmål af type punkt med id 341.804.983
- W: Revert canceled
- E: Handled by bug report queue: java.lang.IllegalStateException: Manglende sammenlægningsmål af type punkt med id 341.804.983


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.IllegalStateException: Manglende sammenlægningsmål af type punkt med id 341.804.983
	at reverter.DataSetCommandMerger.getMergeTarget(DataSetCommandMerger.java:62)
	at reverter.DataSetCommandMerger.mergeNode(DataSetCommandMerger.java:82)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:173)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:46)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:346)
	at reverter.RevertChangesetTask.revertChangeset(RevertChangesetTask.java:159)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:514)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1135)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
	at java.base/java.lang.Thread.run(Thread.java:844)

Attachments (0)

Change History (1)

comment:1 Changed 14 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13981.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.