Modify

Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#16346 closed defect (fixed)

Getting error while doing svn update

Reported by: Biswesh Owned by: team
Priority: normal Milestone:
Component: unspecified Version:
Keywords: svn Cc:

Description

At revision 34237
svn: E205011: Failure occurred processing one or more externals definitions.

I am getting the above error whenever I am doing svn update. I had faced this problem one more time and I had to delete the repo and do checkout branch again to make it work

Here is my svn status -
https://pastebin.com/ZTWfjmFZ

Here is result of svn propget svn:externals -R -
https://pastebin.com/yGDJNva5

Attachments (1)

build.txt (971 bytes) - added by Biswesh 11 months ago.
Result of building the pt_assistant plugin.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 11 months ago by michael2402

For the core problems you can try

cd core
svn cleanup
svn up

If any errors occur there, post them here.

comment:2 Changed 11 months ago by Biswesh

This is the error I get while doing svn up in core

At revision 13879.
svn: E205011: Failure occurred processing one or more externals definitions

comment:3 Changed 11 months ago by Biswesh

Another problem I am facing is that when I am building jar file for the past 2-3 times its getting completed in 1 second although it shows build successful. Previously it used to take around 7-8 seconds. Here I am building PT_Assistant plugin only. I guess even that is not working properly now.

comment:4 Changed 11 months ago by stoecker

Please tell the error and not only the last line. Somwhere before that line there was one or more error. This is the important information.

comment:5 Changed 11 months ago by Biswesh

Sorry for not mentioning it before. This is the error I am getting most of the time.

svn: warning: W205011: Error handling externals definition for 'core/src/org/apache/commons/logging’

Last edited 11 months ago by Biswesh (previous) (diff)

comment:6 Changed 11 months ago by Biswesh

This is what happens when I do svn up -

https://pastebin.com/5Q1fhnaD

comment:7 Changed 11 months ago by Don-vip

Component: External ruleunspecified
Keywords: svn added

comment:8 Changed 11 months ago by michael2402

@Biswesh

This is the relevant part of that paste:

svn: warning: W170013: Unable to connect to a repository at URL 'http://svn.apache.org/repos/asf/commons/proper/jcs/trunk/commons-jcs-core/src/main/java/org/apache/commons/jcs'
 
svn: warning: W205011: Error handling externals definition for 'core/src/org/apache/commons/logging':
svn: warning: W170013: Unable to connect to a repository at URL 'http://svn.apache.org/repos/asf/commons/proper/logging/trunk/src/main/java/org/apache/commons/logging'

Btw, It is best to append those logs as text file and not paste them to an online portal. This makes it easier for us to view them.

Edit: @Don-vip Why is that external reference not using the https link?

Last edited 11 months ago by michael2402 (previous) (diff)

comment:9 Changed 11 months ago by stoecker

Maybe HTTPS is the reason? Probably HTTP is turned off or redirected? SVN by design does not like redirects much.

comment:10 Changed 11 months ago by michael2402

Http is fine for this repo, but the redirect is the reason:

http://svn.apache.org/repos/asf/commons/proper/jcs/trunk/commons-jcs-core/src/main/java/org/apache/commons/jcs


301 Moved Permanently
http://svn.apache.org/repos/asf/commons/proper/jcs/trunk/commons-jcs-core/src/main/java/org/apache/commons/jcs/

We should update that external definition to include the / (and include the https).

Last edited 11 months ago by michael2402 (previous) (diff)

comment:11 in reply to:  8 Changed 11 months ago by Biswesh

Its the middle Error which I always get. Others do not occur everytime. Such warnings used to come before as well but the error didn't occur.
Replying to michael2402:

@Biswesh

This is the relevant part of that paste:

svn: warning: W170013: Unable to connect to a repository at URL 'http://svn.apache.org/repos/asf/commons/proper/jcs/trunk/commons-jcs-core/src/main/java/org/apache/commons/jcs'
 
svn: warning: W205011: Error handling externals definition for 'core/src/org/apache/commons/logging':
svn: warning: W170013: Unable to connect to a repository at URL 'http://svn.apache.org/repos/asf/commons/proper/logging/trunk/src/main/java/org/apache/commons/logging'

Btw, It is best to append those logs as text file and not paste them to an online portal. This makes it easier for us to view them.

Edit: @Don-vip Why is that external reference not using the https link?

comment:12 Changed 11 months ago by stoecker

In 13880/josm:

see #16346 - unify svn:externals style using new style everywhere, append slashes for directories, use https

comment:13 Changed 11 months ago by stoecker

Did last checkin help?

comment:14 in reply to:  10 Changed 11 months ago by stoecker

Replying to michael2402:

Http is fine for this repo, but the redirect is the reason:

http://svn.apache.org/repos/asf/commons/proper/jcs/trunk/commons-jcs-core/src/main/java/org/apache/commons/jcs


301 Moved Permanently
http://svn.apache.org/repos/asf/commons/proper/jcs/trunk/commons-jcs-core/src/main/java/org/apache/commons/jcs/

We should update that external definition to include the / (and include the https).

I doubt that is a reason. SVN does not do a simple GET request and knows, that these are links to directories, as files aren't allowed there.

Changed 11 months ago by Biswesh

Attachment: build.txt added

Result of building the pt_assistant plugin.

comment:15 Changed 11 months ago by Biswesh

svn update works fine now. Thanks a lot for the help. But when I build pt_assistant plugin, it takes 0 seconds to build. Generally it took 7-8 seconds. Is it getting built? Above I have attached the file containing output of the building the plugin .

comment:16 Changed 11 months ago by stoecker

Resolution: fixed
Status: newclosed

Very likely you simply already have built the plugin. A build only does much when it has to do much. It does not do everything always. Try ant clean before if you feel it should take longer.

comment:17 Changed 11 months ago by Biswesh

Ok. Thanks for the help everyone.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.