Modify

#16316 closed defect (fixed)

InvalidPathException at Compression.getCompressedFileOutputStream

Reported by: alborwick@… Owned by: team
Priority: normal Milestone: 18.05
Component: Core Version:
Keywords: template_report windows Cc:

Description

What steps will reproduce the problem?

  1. Download object=relation produced error
  2. Save As ... *.osm file

What is the expected result?

What happens instead?

error msg "... this is nearly always a coding error ... please be kind and file a bug report ..."

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-06 23:56:40 +0200 (Sun, 06 May 2018)
Build-Date:2018-05-06 21:59:07
Revision:13710
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13710 en) Windows 8.1 64-Bit
OS Build number: Windows 8.1 Pro (9600)
Memory Usage: 192 MB / 989 MB (87 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ editgpx (34109)
+ reltoolbox (34130)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.nio.file.InvalidPathException: Illegal char <:> at index 31: %UserProfile%\Downloads\Relation : Far North Cycleway.osm


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.nio.file.InvalidPathException: Illegal char <:> at index 31: C:\Users\Al\Downloads\Relation : Far North Cycleway.osm
	at sun.nio.fs.WindowsPathParser.normalize(Unknown Source)
	at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
	at sun.nio.fs.WindowsPathParser.parse(Unknown Source)
	at sun.nio.fs.WindowsPath.parse(Unknown Source)
	at sun.nio.fs.WindowsFileSystem.getPath(Unknown Source)
	at java.io.File.toPath(Unknown Source)
	at org.openstreetmap.josm.io.Compression.getCompressedFileOutputStream(Compression.java:217)
	at org.openstreetmap.josm.gui.io.importexport.OsmExporter.getOutputStream(OsmExporter.java:79)
	at org.openstreetmap.josm.gui.io.importexport.OsmExporter.doSave(OsmExporter.java:128)
	at org.openstreetmap.josm.gui.io.importexport.OsmExporter.save(OsmExporter.java:92)
	at org.openstreetmap.josm.gui.io.importexport.OsmExporter.exportData(OsmExporter.java:75)
	at org.openstreetmap.josm.gui.io.importexport.OsmExporter.exportData(OsmExporter.java:59)
	at org.openstreetmap.josm.actions.SaveActionBase.doInternalSave(SaveActionBase.java:101)
	at org.openstreetmap.josm.actions.SaveActionBase.doSave(SaveActionBase.java:73)
	at org.openstreetmap.josm.actions.SaveActionBase.doSave(SaveActionBase.java:60)
	at org.openstreetmap.josm.actions.SaveActionBase.actionPerformed(SaveActionBase.java:50)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 11 months ago by Don-vip

Ticket #16317 has been marked as a duplicate of this ticket.

comment:2 Changed 11 months ago by Don-vip

Summary: Download object=relation produced errorInvalidPathException at Compression.getCompressedFileOutputStream

comment:3 Changed 11 months ago by Don-vip

How did you manage to enter ":" in file name?

comment:4 Changed 11 months ago by Don-vip

Keywords: windows added

comment:5 Changed 11 months ago by Don-vip

Milestone: 18.05

comment:6 Changed 11 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13838/josm:

fix #16316 - catch InvalidPathException

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.