Modify

#16299 closed defect (fixed)

Failed to fetch module list in OpenData Plugin Preferences

Reported by: abalosc1 Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin opendata Version:
Keywords: module Cc:

Description

SEVERE: Failed to parse module list document from site 'http://svn.openstreetmap.org/applications/editors/josm/plugins/opendata/modules.txt%<?modules=>'. Skipping site. Exception was: org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParseException: java.io.IOException: Illegal entry in module list.
org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParseException: java.io.IOException: Illegal entry in module list.

at org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParser.parse(ModuleListParser.java:118)
at org.openstreetmap.josm.plugins.opendata.core.modules.ReadRemoteModuleInformationTask.parseModuleListDocument(ReadRemoteModuleInformationTask.java:278)
at org.openstreetmap.josm.plugins.opendata.core.modules.ReadRemoteModuleInformationTask.realRun(ReadRemoteModuleInformationTask.java:323)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

Caused by: java.io.IOException: Illegal entry in module list.

at org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParser.parse(ModuleListParser.java:99)
... 9 more

2018-05-17 12:46:36.466 SEVERE: Failed to parse module list document from site 'http://svn.openstreetmap.org/applications/editors/josm/plugins/opendata/modules.txt%<?modules=>'. Skipping site. Exception was: org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParseException: java.io.IOException: Illegal entry in module list.
org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParseException: java.io.IOException: Illegal entry in module list.

at org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParser.parse(ModuleListParser.java:118)
at org.openstreetmap.josm.plugins.opendata.core.modules.ReadRemoteModuleInformationTask.parseModuleListDocument(ReadRemoteModuleInformationTask.java:278)
at org.openstreetmap.josm.plugins.opendata.core.modules.ReadRemoteModuleInformationTask.realRun(ReadRemoteModuleInformationTask.java:323)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

Caused by: java.io.IOException: Illegal entry in module list.

at org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParser.parse(ModuleListParser.java:99)

Attachments (0)

Change History (3)

comment:1 Changed 17 months ago by stoecker

Should use https in the link and many other places. Also the icons could be inline in the text instead of separate zip. For JOSM server we fixed that years ago.

Wouldn't the modules txt better be in JOSM wiki like the recent pt assistant stuff. SVN may be dropped or change?

comment:2 in reply to:  1 Changed 17 months ago by Don-vip

Replying to stoecker:

Should use https in the link and many other places. Also the icons could be inline in the text instead of separate zip. For JOSM server we fixed that years ago.

Wouldn't the modules txt better be in JOSM wiki like the recent pt assistant stuff. SVN may be dropped or change?

Sure. I keep this in mind for the future (like next year :)

comment:3 Changed 17 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o34196:34197].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.