Modify

Opened 4 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#16290 closed enhancement (fixed)

Ubuntu Bionic need JRE update

Reported by: matthewdarwin Owned by: team
Priority: normal Milestone: 18.08
Component: Ubuntu package Version:
Keywords: template_report java11 Cc:

Description

What steps will reproduce the problem?

  1. set /etc/apt/sources.list.d/josm.list to deb https://josm.openstreetmap.de/apt bionic universe
  2. sudo apt install josm
  3. notice that it pulls in JRE8

What is the expected result?

Expect JOSM has reasonable font size on large 4K UHD monitors.

What happens instead?

Get a very small font that is hard to read
JRE8 is very old and JOSM doesn't work well with JRE8 with 4K UHD monitors.

Please provide any additional information below. Attach a screenshot if possible.

I changed /usr/bin/josm to have the line:

JAVA_CMDS="${JAVA_CMDS} /usr/lib/jvm/java-11-openjdk/bin/java /usr/lib/jvm/java-11-openjdk-$ARCH/bin/java /usr/lib/jvm/java-11-oracle/bin/java"

then already having installed JRE11, the following commands work as expected:

export JAVA_OPTS="-Xms2048M -Xmx6114M -Dsun.java2d.uiScale=2"
/usr/bin/josm

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-06 23:56:40 +0200 (Sun, 06 May 2018)
Revision:13710
Build-Date:2018-05-06 21:59:07
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13710 en) Linux Ubuntu 18.04 LTS
Memory Usage: 2048 MB / 6114 MB (1681 MB allocated, but free)
Java version: 10.0.1+10-Ubuntu-3ubuntu1, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x2160
Maximum Screen Size: 3840x2160
Java package: openjdk-11-jre:amd64-10.0.1+10-3ubuntu1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true, -Dsun.java2d.uiScale=2]

Plugins:
+ ImproveOsm (133)
+ Mapillary (v1.5.12+post13643)
+ QuickLabel (1524508484)
+ apache-commons (34109)
+ apache-http (34109)
+ colorscheme (34109)
+ conflation (0.5.8)
+ continuosDownload (68)
+ contourmerge (1032)
+ geochat (34109)
+ geojson (80)
+ jts (34038)
+ reverter (34109)
+ tageditor (34109)
+ todo (30304)
+ turnlanes-tagging (263)
+ undelete (34109)
+ utilsplugin2 (34109)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (13)

comment:1 Changed 4 months ago by Don-vip

Component: CoreUbuntu package
Owner: changed from team to bastiK

comment:2 Changed 4 months ago by Don-vip

Keywords: java11 added
Milestone: 18.06
Type: defectenhancement

Java 8 is not the latest version but it is not very old neither: this the current LTS version and the preferred version to run JOSM.

Java 11 has not been released yet. What you are in fact using in openjdk-11 package is currently Java 10. But with the new pace of Java releases, Debian/Ubuntu maintainers are forced to use this trick in order to update to Java 11 once it is released in September.

You will notice there is a critical bug with this version of Java in Ubuntu (#15851), so we must wait for this bug correction to be backported to bionic before switching:

https://bugs.launchpad.net/ubuntu/+source/ca-certificates-java/+bug/1769013

comment:3 Changed 4 months ago by matthewdarwin

Thanks for the comments. I believe the issue would be resolved JRE9/10 as well. The problem is definitely we JRE8 and earlier.

https://help.openstreetmap.org/questions/61236/how-can-i-scale-josm-for-a-4kuhd-display

comment:5 Changed 3 months ago by Don-vip

Owner: changed from bastiK to team

comment:6 Changed 3 months ago by Don-vip

Milestone: 18.0618.07

comment:7 Changed 2 months ago by Don-vip

Still waiting... https://bugs.launchpad.net/ubuntu/+source/ca-certificates-java/+bug/1770553
This is so slow! just to backport a fix :(

comment:8 Changed 2 months ago by Don-vip

Finally there is some activity in the bugs, it should be available by July 26th (release date of 18.04.1)

comment:9 Changed 2 months ago by Don-vip

Or not. I really don't understand how Ubuntu works.

comment:10 Changed 8 weeks ago by Don-vip

Milestone: 18.0718.08

comment:11 Changed 7 weeks ago by Don-vip

It has been backported finally! So we can now address this issue.

comment:12 Changed 7 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

In 14071/josm:

fix #16290 - prefer openjdk-11 over openjdk-8; drop detection of Oracle runtimes

comment:13 Changed 7 weeks ago by Don-vip

In 14072/josm:

fix #16290 - add java11-runtime to debian/control

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.