Modify

#16269 closed defect (fixed)

IAE: No valid coordinates have been found

Reported by: ff5722 Owned by: ff5722
Priority: normal Milestone:
Component: Plugin opendata Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Import file to be read with opendata plugin

What is the expected result?

successful import

What happens instead?

See images, followed by the error message below

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-06 23:56:40 +0200 (Sun, 06 May 2018)
Build-Date:2018-05-06 21:59:07
Revision:13710
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13710 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1709 (16299)
Memory Usage: 699 MB / 1820 MB (519 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ FastDraw (34109)
+ Mapillary (v1.5.12+post13643)
+ apache-commons (34109)
+ apache-http (34109)
+ buildings_tools (34109)
+ ejml (34126)
+ geotools (34125)
+ importvec (34109)
+ jts (34038)
+ opendata (34153)
+ reverter (34109)
+ utilsplugin2 (34109)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: No valid coordinates have been found.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (52) of main
java.lang.IllegalArgumentException: No valid coordinates have been found.
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.SpreadSheetReader.doParse(SpreadSheetReader.java:165)
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.SpreadSheetReader.parse(SpreadSheetReader.java:291)
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.OdsReader.parseDataSet(OdsReader.java:35)
	at org.openstreetmap.josm.plugins.opendata.core.io.tabular.OdsImporter.parseDataSet(OdsImporter.java:29)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.loadLayer(OsmImporter.java:121)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.importData(OsmImporter.java:98)
	at org.openstreetmap.josm.plugins.opendata.core.io.AbstractImporter.importData(AbstractImporter.java:55)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:95)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:361)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:314)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (4)

Capture.JPG (30.5 KB) - added by ff5722 18 months ago.
Capture2.JPG (28.2 KB) - added by ff5722 18 months ago.
pnj.ods (15.7 KB) - added by ff5722 18 months ago.
pnj2.csv (13.6 KB) - added by ff5722 18 months ago.

Download all attachments as: .zip

Change History (8)

Changed 18 months ago by ff5722

Attachment: Capture.JPG added

Changed 18 months ago by ff5722

Attachment: Capture2.JPG added

comment:1 Changed 18 months ago by Don-vip

Owner: changed from Don-vip to ff5722
Status: newneedinfo

Can you please attach your file?

comment:2 Changed 18 months ago by Don-vip

Summary: Opendata plugin unexpected error and cannot updateIAE: No valid coordinates have been found

Changed 18 months ago by ff5722

Attachment: pnj.ods added

Changed 18 months ago by ff5722

Attachment: pnj2.csv added

comment:3 Changed 18 months ago by ff5722

Ok looks like I forgot to add the headers, so my fault. But it seems strange that the error I got was not 'no valid coordinates', but the popup windows saying the plugin was not found. If I got the 'no valid coordinates' message directly it would be easy to see my own mistake.

From the attachment the file 'pnj2.csv' works fine.

comment:4 Changed 18 months ago by Don-vip

Resolution: fixed
Status: needinfoclosed

Fixed in [o34185:34186].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ff5722.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.