Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#16221 closed defect (duplicate)

auto-tools gives an error when pressing shift

Reported by: anonymous Owned by: Rub21
Priority: major Milestone:
Component: Plugin auto_tools Version:
Keywords: auto-tools; shift Cc:

Description

What steps will reproduce the problem?

  1. ctrl+shift+down
  2. ctrl+shift+down
  3. shift - to select multiple values

What is the expected result?

downloading data

What happens instead?

gives an error report

Please provide any additional information below. Attach a screenshot if possible.

the plug-in is up to date

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-26 22:16:39 +0200 (Mon, 26 Mar 2018)
Build-Date:2018-03-26 20:45:23
Revision:13576
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13576 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 687 MB / 910 MB (248 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 2560x1440
Maximum Screen Size: 2560x1440
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (34109)
+ ImproveOsm (132)
+ Mapillary (v1.5.10)
+ OpenStreetCam (144)
+ RoadSigns (34109)
+ apache-commons (34109)
+ apache-http (34109)
+ auto_tools (1518973818)
+ buildings_tools (34109)
+ download_along (34081)
+ ejml (34126)
+ geojson (80)
+ geotools (34125)
+ graphview (34109)
+ jna (34038)
+ jts (34038)
+ log4j (34038)
+ measurement (34109)
+ opendata (34153)
+ pbf (34109)
+ poly (34098)
+ reltoolbox (34130)
+ reverter (34109)
+ scripting (30783)
+ tageditor (34109)
+ todo (30304)
+ turnlanes (34146)
+ turnlanes-tagging (263)
+ turnrestrictions (34129)
+ utilsplugin2 (34109)
+ waydownloader (34109)

Tagging presets:
+ %UserProfile%\Desktop\Tools\mapcss\signpost.xml
+ %UserProfile%\Desktop\Tools\mapcss\preset\turning_smthg.xml
+ %UserProfile%\Desktop\Tools\mapcss\status\statuspreset(1).xml

Map paint styles:
+ %UserProfile%\Desktop\Tools\mapcss\status.mapcss
- %UserProfile%\Desktop\Tools\mapcss\turn_lanes.mapcss
- %UserProfile%\Desktop\Tools\mapcss\v4_Lane and road attributes.mapcss
- %UserProfile%\Desktop\Tools\mapcss\number of lanes.mapcss
+ %UserProfile%\Desktop\Tools\mapcss\user edits.mapcss
- %UserProfile%\Desktop\Tools\mapcss\modified objects.mapcss
- %UserProfile%\Desktop\Tools\mapcss\recent changes_2016.mapcss
- %UserProfile%\Desktop\Tools\mapcss\roadlength.mapcss
- %UserProfile%\Desktop\Tools\mapcss\turn_restrictions.mapcss
+ %UserProfile%\Desktop\US build up\San Jose\road geometry\road_geometry.v3.mapcss
- %UserProfile%\Desktop\Tools\mapcss\links_v2.mapcss
- %UserProfile%\Desktop\Tools\mapcss\errors.mapcss
+ %UserProfile%\Desktop\Tools\mapcss\improve_OSM.mapcss

Last errors/warnings:
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7460862%2C41.8332467%2C-87.6861763%2C41.8595893&per_page=200&_start_key=JkAujQWfmS4ndSyXnCddyA&_start_key_time=1457298015118!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7460862%2C41.8332467%2C-87.6861763%2C41.8595893&per_page=200&_start_key=JkAujQWfmS4ndSyXnCddyA&_start_key_time=1457298015118
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7612782%2C41.8081728%2C-87.6414586%2C41.8608678&per_page=200&_start_key=iA6XhSNQJOnwA3yW2PJl0w&_start_key_time=1503242067237!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7612782%2C41.8081728%2C-87.6414586%2C41.8608678&per_page=200&_start_key=iA6XhSNQJOnwA3yW2PJl0w&_start_key_time=1503242067237
- W: Could not read from URL https://a.mapillary.com/v3/sequences?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7598191%2C41.8221822%2C-87.6399995%2C41.8748656!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/sequences?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7598191%2C41.8221822%2C-87.6399995%2C41.8748656
- E: Handled by bug report queue: java.lang.NullPointerException
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7598191%2C41.8221822%2C-87.6399995%2C41.8748656!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7598191%2C41.8221822%2C-87.6399995%2C41.8748656
- W: Could not read from URL https://a.mapillary.com/v3/detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7598191%2C41.8221822%2C-87.6399995%2C41.8748656!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=-87.7598191%2C41.8221822%2C-87.6399995%2C41.8748656
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.auto_tools.actions.SplittingTool$1.keyPressed(SplittingTool.java:96)
	at java.awt.AWTEventMulticaster.keyPressed(Unknown Source)
	at java.awt.AWTEventMulticaster.keyPressed(Unknown Source)
	at java.awt.AWTEventMulticaster.keyPressed(Unknown Source)
	at java.awt.Component.processKeyEvent(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

Capture.JPG (50.3 KB) - added by anonymous 3 years ago.

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by anonymous

Attachment: Capture.JPG added

comment:1 Changed 3 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13947.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Rub21.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.