Modify

Opened 12 months ago

Closed 11 months ago

Last modified 6 months ago

#16157 closed defect (fixed)

validator about landuse and building on the same object

Reported by: dieterdreist Owned by: Klumbumbus
Priority: normal Milestone: 18.04
Component: Core validator Version: latest
Keywords: template_report, landuse, building Cc:

Description

What steps will reproduce the problem?

  1. add landuse and building tags on the same object

What is the expected result?

nothing

What happens instead?

"suspicious tagging combination" is raised

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-04-02 23:20:00 +0200 (Mon, 02 Apr 2018)
Build-Date:2018-04-03 01:33:52
Revision:13595
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13595 en) Mac OS X 10.13.3
OS Build number: Mac OS X 10.13.3 (17D102)
Memory Usage: 878 MB / 1820 MB (182 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 188875522 1920x1080, Display 458628992 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (1511895663)
+ Create_grid_of_ways (34109)
+ ImportImagePlugin (34109)
+ PicLayer (34109)
+ ShapeTools (1230)
+ apache-commons (34109)
+ buildings_tools (34109)
+ editgpx (34109)
+ ejml (34126)
+ fieldpapers (v0.4.3)
+ geochat (34109)
+ geojson (80)
+ geotools (34125)
+ imagery_offset_db (34109)
+ jts (34038)
+ log4j (34038)
+ mbtiles (a3e491d)
+ measurement (34109)
+ o5m (34109)
+ osmarender (34096)
+ pbf (34109)
+ photo_geotagging (34109)
+ reltoolbox (34130)
+ reverter (34109)
+ undelete (34109)
+ utilsplugin2 (34109)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect

Attachments (1)

suspicious-tag-combine-landuse-building.osm (4.0 KB) - added by dieterdreist 12 months ago.
example suspicious tag combination building landuse

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 months ago by Klumbumbus

Which specific tags? I can't think of a useful usecase atm. Landuse is usually put on larger areas.

comment:2 Changed 12 months ago by dieterdreist

for example landuse=retail in a block (i.e. no outdoor area associated). Generally I don’t think it is a problem to have smaller landuse units, mapping style is not something josm should care for.

comment:3 Changed 12 months ago by stoecker

Please give an example (i.e. an osm file). Sure does josm validate mapping style. That's the whole idea of the validator.

comment:4 Changed 12 months ago by Don-vip

Owner: changed from team to dieterdreist
Status: newneedinfo

Changed 12 months ago by dieterdreist

example suspicious tag combination building landuse

comment:5 Changed 12 months ago by dieterdreist

Owner: dieterdreist deleted
Status: needinfonew

comment:6 Changed 11 months ago by Klumbumbus

Owner: set to Klumbumbus
Resolution: fixed
Status: newclosed

In 13645/josm:

fix #16157 - don't warn about landuse=retail + building combination

comment:7 Changed 11 months ago by Klumbumbus

I checked osmwiki:Key:landuse and retail seems to be really the only value which can be limited to a building. All other landuse tags have related sourrounding infrastructure.

comment:8 Changed 11 months ago by Klumbumbus

Milestone: 18.04

comment:9 Changed 11 months ago by maraf

building together with landuse=retail is indeed strange combination. I always remove landuse from such objects, building=retail is just enough.

comment:10 Changed 11 months ago by anonymous

you should not do it, building is about a building type and landuse about current landuse. Also people might only look ar landuse and drop the buildings.

comment:11 Changed 11 months ago by anonymous

In that case I would create another area object and tag it as landuse=retail. One for building and one for landuse is good method, as there is no confusing about which object some tags refer to, e.g. name.
Besides, I don't really understand why this change has to be limited only to landuse=retail? The next good condidate is landuse=commercial.

comment:12 Changed 6 months ago by Klumbumbus

In 14275/josm:

fix #16783, see #16157 - fix validator warning message (modified patch by naoliv)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.