Modify

#16094 closed defect (fixed)

Open Custom URL

Reported by: GOwin Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Use the Open Custom URL of the UtilsPlugin2 with the ask every time option enabled
  2. Dialog box will appear asking for a URL to use.
  3. Press Cancel (or hit ESC key) and the highlighted URL will be launched

What is the expected result?

Dialog box should disappear, as expected in any cancel operation.

What happens instead?

Highlighted URL (the last selected) is launched.

Please provide any additional information below. Attach a screenshot if possible.


URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-04 16:20:37 +0100 (Sun, 04 Mar 2018)
Build-Date:2018-03-04 15:24:13
Revision:13500
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13500 en) Linux Ubuntu 16.04.4 LTS
Memory Usage: 1723 MB / 3500 MB (346 MB allocated, but free)
Java version: 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
Java package: openjdk-8-jre:amd64-8u151-b12-0ubuntu0.16.04.2
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Program arguments: [${HOME}/Documents/default.joz]
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1515942663)
+ FastDraw (33731)
+ Mapillary (v1.5.10)
+ OpeningHoursEditor (33876)
+ QuickLabel (1513862916)
+ apache-commons (33668)
+ apache-http (32699)
+ buildings_tools (34040)
+ changeset-viewer (1518145917)
+ continuosDownload (68)
+ contourmerge (1032)
+ ejml (32680)
+ fieldpapers (v0.4.3)
+ geojson (73)
+ geotools (33958)
+ imagery_offset_db (33774)
+ jts (32699)
+ log4j (32699)
+ measurement (33760)
+ merge-overlap (34056)
+ namemanager (33872)
+ reverter (34036)
+ routing (34054)
+ tageditor (33806)
+ tagging-preset-tester (33898)
+ terracer (33839)
+ todo (30303)
+ tofix (1517601216)
+ turnlanes-tagging (260)
+ turnrestrictions (33780)
+ utilsplugin2 (33991)
+ waydownloader (33910)

Tagging presets:
+ ${HOME}/Documents/Projects/#Kaart/JOSM/Reviewed_Features/reviewed_preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/PhilippinesAddresses&preset

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- ${HOME}/Documents/Projects/#Kaart/JOSM/Kaart Styles 3.1.mapcss
+ ${HOME}/Documents/Projects/#Kaart/JOSM/geometry_adjusted_paint.mapcss.css
- ${HOME}/Documents/Projects/#Kaart/JOSM/Reviewed_Features/reviewed_features.mapcss
- https://github.com/osmlab/appledata/archive/josm_paint_inline_validation.zip

Last errors/warnings:
- E: java.lang.ClassCastException
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- W: java.net.SocketException: Socket closed
- E: Error header: The changeset 57194980 was closed at 2018-03-15 02:26:54 UTC
- E: org.openstreetmap.josm.io.ChangesetClosedException: The changeset 57194980 was closed at 2018-03-15 02:26:54 UTC
- E: Error - <html>Failed to upload to changeset <strong>57,194,980</strong><br>because it has already been closed on 2018-03-15 10:26:54.
- W: 1 problems occured during upload/save

Attachments (1)

16094.png (33.8 KB) - added by Don-vip 13 months ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 13 months ago by Don-vip

Component: CorePlugin utilsplugin2
Summary: [UtilsPlugin2] Open Custom URLOpen Custom URL

Changed 13 months ago by Don-vip

Attachment: 16094.png added

comment:2 Changed 13 months ago by Don-vip

Description: modified (diff)

comment:3 Changed 11 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o34221:34222].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.