Modify

Opened 12 months ago

Closed 12 months ago

Last modified 11 months ago

#16080 closed defect (fixed)

/etc/default/josm should be marked as configuration file

Reported by: alonessro Owned by: bastiK
Priority: normal Milestone: 18.03
Component: Ubuntu package Version: tested
Keywords: template_report Cc: sebastic

Description

What steps will reproduce the problem?

  1. Install the Debian package from https://josm.openstreetmap.de/wiki/Download#Ubuntu
  2. Configure options in /etc/default/josm
  3. Update the josm package

What is the expected result?

The package should mark /etc/default/josm as config file so the update should ask the user when file is changed

What happens instead?

The content of /etc/default/josm is overridden by the package default

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-04 16:20:37 +0100 (Sun, 04 Mar 2018)
Build-Date:2018-03-04 15:24:13
Revision:13500
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13500 en_GB) Linux Ubuntu 17.10
Memory Usage: 931 MB / 1820 MB (273 MB allocated, but free)
Java version: 1.8.0_151-8u151-b12-0ubuntu0.17.10.2-b12, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u151-b12-0ubuntu0.17.10.2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true, -Djosm.pref=<josm.pref>, -Djosm.userdata=<josm.userdata>, -Djosm.cache=<josm.cache>]

Plugins:
+ FixAddresses (33963)
+ HouseNumberTaggingTool (34074)
+ ImproveOsm (126)
+ Mapillary (v1.5.10)
+ OpeningHoursEditor (33876)
+ Tracer2 (33908)
+ apache-commons (33668)
+ apache-http (32699)
+ ejml (32680)
+ epci-fr (33521)
+ geochat (33982)
+ geotools (33958)
+ imagery_offset_db (33774)
+ jts (32699)
+ log4j (32699)
+ measurement (33760)
+ opendata (34072)
+ public_transport (33817)
+ public_transport_layer (33900)
+ reverter (34036)
+ turnlanes (33858)
+ turnrestrictions (33780)
+ utilsplugin2 (33991)
+ waydownloader (33910)
+ wikipedia (34079)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1

Last errors/warnings:
- W: Invalid jar file ''<josm.userdata>/plugins/public_transport_layer.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/geochat.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/utilsplugin2.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/wikipedia.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/HouseNumberTaggingTool.jar.new'' (exists: false, canRead: false)
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Warning: Failed to scan file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' for module information. Skipping.
- W: Update modules - org.openstreetmap.josm.plugins.opendata.core.modules.ModuleHandler$UpdateModulesMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- E: Failed to parse module list document from site 'http://svn.openstreetmap.org/applications/editors/josm/plugins/opendata/modules.txt%<?modules=>'. Skipping site. Exception was: org.openstreetmap.josm.plugins.opendata.core.modules.ModuleListParseException: java.io.IOException: Illegal entry in module list.
- W: Warning: Failed to scan file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' for module information. Skipping.

Attachments (0)

Change History (9)

comment:1 Changed 12 months ago by Don-vip

Cc: sebastic added

@sebastic: what do we need to do to solve this ticket?

comment:2 Changed 12 months ago by sebastic

If the package is built using the standard Debian build tools, all files under /etc will be marked as conffiles automatically, this is the case for the josm package in Debian:

$ dpkg-deb -R ../josm_0.0.svn13500+dfsg-1_all.deb /tmp/josm
$ cat /tmp/josm/DEBIAN/conffiles 
/etc/default/josm

I don't know how the package for the PPA is built, but adding the conffiles file in linux/tested/DEBIAN/ & linux/latest/DEBIAN may suffice.

comment:3 Changed 12 months ago by Don-vip

Extract from our build script:

${TMPDIR}/.build: ${TMPDIR}/revision
        svn export ${DEBSOURCE} ${TMPDIR}/deb-copy
        chmod -R g-w ${TMPDIR}/deb-copy
        cp ${DOWNLOAD}/josm-snapshot-${REVISION}.jar ${TMPBINDIR}/josm-1.5.svn${VERSION}.jar
        chmod 644 ${TMPBINDIR}/josm-1.5.svn${VERSION}.jar
        ln -s josm-1.5.svn${VERSION}.jar ${TMPBINDIR}/${package}.jar
        gzip -9 ${TMPDIR}/deb-copy/usr/share/man/man1/${package}.1
        sed -i "s/{{VERSION}}/${VERSION}/" ${TMPDIR}/deb-copy/DEBIAN/control
        fakeroot dpkg -b ${TMPDIR}/deb-copy ${DEBNAME}
        touch ${TMPDIR}/.build

addrepo: parameter-check
        for code in ${DISTS} ; do \
          echo "Adding ${DEBNAME} to repository $$code" ; \
          reprepro -V --keepunreferencedfiles --basedir ${DEBREPOSITORY} includedeb $$code ${DEBNAME} ; \
          mkdir ${DEBREPOSITORY}/dists/$$code/universe/i18n 2> /dev/null ; \
          cp -f ${DEBSOURCE}/../Index ${DEBREPOSITORY}/dists/$$code/universe/i18n/Index ; \
        done

cleanrepo: parameter-check
        for code in ${DISTS} ; do \
          reprepro -V --keepunreferencedfiles --basedir ${DEBREPOSITORY} remove $$code ${package} ; \
        done

I see we're using dpkg while you're using dpkg-deb, maybe that's the problem?

comment:4 Changed 12 months ago by Don-vip

Milestone: 18.03

comment:5 in reply to:  3 Changed 12 months ago by sebastic

Replying to Don-vip:

I see we're using dpkg while you're using dpkg-deb, maybe that's the problem?

No, that just creates a .deb file from a directory. dpkg -b uses dpkg-deb to create the package.

The package in Debian calls dh_installdeb as part of the build process which marks all files under /etc as conffiles.

Because the PPA build is not a binary package built from a proper source package, you'll need to manage the content of the DEBIAN directory yourself since you cannot rely on the packaging tools to generate those files for you.

comment:6 Changed 12 months ago by Don-vip

OK thanks for the explanation :)

comment:7 Changed 12 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13514/josm:

fix #16080 - mark /etc/default/josm as configuration file

comment:8 Changed 11 months ago by Don-vip

Crap, it doesn't work:

dpkg-deb: error: conffile '/etc/default/josm' does not appear in package

comment:9 Changed 11 months ago by Don-vip

In 13547/josm:

see #16080 - fix conffiles for josm-latest debian package

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.