Modify

Opened 5 months ago

Closed 5 months ago

Last modified 4 months ago

#16060 closed defect (fixed)

NPE in Relation editor dialog after creating a copy of a relation

Reported by: josm@… Owned by: team
Priority: normal Milestone: 18.03
Component: Core Version:
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. Click on a relation in the relations panel
  2. Click the create a copy of this relation and open it in another editor window button

What is the expected result?

Can edit relation

What happens instead?

JOSM has crashed box appears

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-04 16:20:37 +0100 (Sun, 04 Mar 2018)
Build-Date:2018-03-04 15:24:13
Revision:13500
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13500 en_GB) Linux Ubuntu 17.10
Memory Usage: 506 MB / 1292 MB (344 MB allocated, but free)
Java version: 1.8.0_151-8u151-b12-0ubuntu0.17.10.2-b12, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u151-b12-0ubuntu0.17.10.2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ reverter (34036)
+ terracer (33839)
+ undelete (33980)
+ utilsplugin2 (33991)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-1 (18) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.dialogs.relation.actions.AbstractRelationEditorAction.canDownload(AbstractRelationEditorAction.java:57)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.DownloadIncompleteMembersAction.updateEnabledState(DownloadIncompleteMembersAction.java:60)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.DownloadIncompleteMembersAction.<init>(DownloadIncompleteMembersAction.java:43)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$LeftButtonToolbar.<init>(GenericRelationEditor.java:667)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.<init>(GenericRelationEditor.java:223)
	at org.openstreetmap.josm.gui.dialogs.relation.RelationEditor.getEditor(RelationEditor.java:116)
	at org.openstreetmap.josm.actions.relation.DuplicateRelationAction.duplicateRelationAndLaunchEditor(DuplicateRelationAction.java:35)
	at org.openstreetmap.josm.actions.relation.DuplicateRelationAction.actionPerformed(DuplicateRelationAction.java:48)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at org.GNOME.Accessibility.AtkWrapper$5.dispatchEvent(AtkWrapper.java:700)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (1)

Screenshot_20180306_204550.png (242.5 KB) - added by josm@… 5 months ago.
Screenshot directly after clicking the button. Relation editor never opens

Download all attachments as: .zip

Change History (10)

Changed 5 months ago by josm@…

Screenshot directly after clicking the button. Relation editor never opens

comment:1 Changed 5 months ago by Don-vip

Keywords: regression added
Milestone: 18.03

comment:2 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13509/josm:

fix #16060 - NPE + minor fixes

comment:3 Changed 4 months ago by Don-vip

Summary: Relation editor dialog crashes after creating a copy of a relationNPE in Relation editor dialog after creating a copy of a relation

comment:4 Changed 4 months ago by Don-vip

Ticket #16079 has been marked as a duplicate of this ticket.

comment:5 Changed 4 months ago by Don-vip

Ticket #16083 has been marked as a duplicate of this ticket.

comment:6 Changed 4 months ago by Don-vip

Ticket #16099 has been marked as a duplicate of this ticket.

comment:7 Changed 4 months ago by Don-vip

Ticket #16114 has been marked as a duplicate of this ticket.

comment:8 Changed 4 months ago by Don-vip

Ticket #16116 has been marked as a duplicate of this ticket.

comment:9 Changed 4 months ago by Klumbumbus

Ticket #16125 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.