Modify

Opened 4 months ago

Closed 4 months ago

#16020 closed defect (duplicate)

The Help did not want to open the submenu

Reported by: poliakoffmykhailo Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-01-28 23:08:56 +0100 (Sun, 28 Jan 2018)
Build-Date:2018-01-28 22:25:44
Revision:13367
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13367 uk) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1709 (16299)
Memory Usage: 989 MB / 989 MB (318 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1280x800
Maximum Screen Size: 1280x800
Dataset consistency test: No problems found

Plugins:
+ ElevationProfile (33815)
+ FastDraw (33731)
+ reltoolbox (33708)
+ reverter (34036)
+ undelete (33980)
+ utilsplugin2 (33991)

Tagging presets:
+ https://raw.githubusercontent.com/jacobbraeutigam/JOSM_Preset_street_cabinet/master/street_cabinet.xml
+ https://raw.githubusercontent.com/ruosm-presets/literan-moscow/master/russian_shops.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Surveillance&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Payment_Method_RU&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/MissingWeekdays&zip=1
+ http://www.openrailwaymap.org/validator/de-openrailwaymap.validator.mapcss

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Length must be >= 0.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Length must be >= 0.
	at javax.swing.text.GlyphPainter2.getBoundedPosition(Unknown Source)
	at javax.swing.text.GlyphView.getBreakWeight(Unknown Source)
	at javax.swing.text.html.InlineView.getBreakWeight(Unknown Source)
	at javax.swing.text.ParagraphView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.ParagraphView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.ParagraphView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.TableView$CellView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.TableView.checkSingleColumnCell(Unknown Source)
	at javax.swing.text.html.TableView.calculateColumnRequirements(Unknown Source)
	at javax.swing.text.html.TableView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.TableView$CellView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.TableView.checkSingleColumnCell(Unknown Source)
	at javax.swing.text.html.TableView.calculateColumnRequirements(Unknown Source)
	at javax.swing.text.html.TableView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.TableView$CellView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.TableView.checkSingleColumnCell(Unknown Source)
	at javax.swing.text.html.TableView.calculateColumnRequirements(Unknown Source)
	at javax.swing.text.html.TableView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.getMinimumSpan(Unknown Source)
	at javax.swing.text.html.BlockView.getMinimumSpan(Unknown Source)
	at javax.swing.text.BoxView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.html.BlockView.calculateMinorAxisRequirements(Unknown Source)
	at javax.swing.text.BoxView.checkRequests(Unknown Source)
	at javax.swing.text.BoxView.setSpanOnAxis(Unknown Source)
	at javax.swing.text.BoxView.layout(Unknown Source)
	at javax.swing.text.BoxView.setSize(Unknown Source)
	at javax.swing.plaf.basic.BasicTextUI$RootView.setSize(Unknown Source)
	at javax.swing.plaf.basic.BasicTextUI.viewToModel(Unknown Source)
	at javax.swing.text.DefaultCaret.positionCaret(Unknown Source)
	at javax.swing.text.DefaultCaret.adjustCaret(Unknown Source)
	at javax.swing.text.DefaultCaret.adjustCaretAndFocus(Unknown Source)
	at javax.swing.text.DefaultCaret.mousePressed(Unknown Source)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 4 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14968.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.