Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#15969 closed defect (fixed)

when uploading: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset

Reported by: aseerel4c26 Owned by: team
Priority: blocker Milestone: 18.02
Component: Core Version: latest
Keywords: template_report uploading regression Cc: Don-vip

Description (last modified by aseerel4c26)

What steps will reproduce the problem?

(not sure if that will always happen - but this is what I did:

  1. could be (I do not remember if it was in this JOSM session) that I tried to open a saved data layer, forbid uploading, downloaded OSM data into it. ... tried to test ticket 8039 .
  2. make some edits which involved a way split (which is part of several route relations) and changing the way's tags
  3. upload

What is the expected result?

upload succeeds

What happens instead?

upload is partially done. Changeset is not closed ( https://www.openstreetmap.org/changeset/56471159 ) by JOSM. Apparently the data was uploaded correctly, though. When removing this data layer, JOSM warns that the layer has not yet been uploaded.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-02-18 17:20:31 +0100 (Sun, 18 Feb 2018)
Revision:13439
Build-Date:2018-02-18 17:32:43
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13439 de) Linux Linux
Memory Usage: 374 MB / 2048 MB (168 MB allocated, but free)
Java version: 9.0.4+11, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on, -Dswing.aatext=true]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33876)
+ buildings_tools (34040)
+ measurement (33760)
+ reverter (34036)
+ terracer (33839)
+ todo (30303)
+ turnrestrictions (33780)
+ undelete (33980)
+ utilsplugin2 (33991)

Tagging presets:
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'Waypoint'
- E: Fehler beim Laden des Bildes 'Campground'
- E: Fehler beim Laden des Bildes 'Flag'
- E: Fehler beim Laden des Bildes 'Flag'
- E: Fehler beim Laden des Bildes 'Flag'
- E: Fehler beim Laden des Bildes 'Flag'
- E: Fehler beim Laden des Bildes 'Flag'
- E: Fehler beim Laden des Bildes 'Flag'
- E: Fehler beim Laden des Bildes 'Car'
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Way id=-47494 version=0 MVT nodes=[{Node id=431153943 version=4 V lat=50.0124611,lon=8.7968209}, {Node id=431153944 version=5 V lat=50.0124722,lon=8.7992457}]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (52)
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be modified in read-only dataset: {Way id=-47494 version=0 MVT nodes=[{Node id=431153943 version=4 V lat=50.0124611,lon=8.7968209}, {Node id=431153944 version=5 V lat=50.0124722,lon=8.7992457}]}
	at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDatasetNotReadOnly(OsmPrimitive.java:282)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.setOsmId(OsmPrimitive.java:315)
	at org.openstreetmap.josm.io.DiffResultProcessor.postProcess(DiffResultProcessor.java:138)
	at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:561)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesInChunks(OsmServerWriter.java:174)
	at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:218)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:250)
	at org.openstreetmap.josm.gui.io.AsynchronousUploadPrimitivesTask.realRun(AsynchronousUploadPrimitivesTask.java:131)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
	at java.base/java.lang.Thread.run(Thread.java:844)

Attachments (0)

Change History (8)

comment:1 Changed 3 months ago by aseerel4c26

Description: modified (diff)

comment:2 Changed 3 months ago by aseerel4c26

Cc: Don-vip added

comment:3 Changed 3 months ago by Don-vip

Keywords: regression added
Milestone: 18.02
Priority: majorblocker

comment:4 Changed 3 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13440/josm:

fix #15969 - upload broken (regression from r13434)

comment:5 Changed 3 months ago by Don-vip

New latest version should be available in 10 minutes.

comment:6 in reply to:  5 Changed 3 months ago by aseerel4c26

Replying to Don-vip:
awesome, thank you! :-)

With version 13440 a upload worked without problems.

comment:7 Changed 3 months ago by Don-vip

Ticket #15971 has been marked as a duplicate of this ticket.

comment:8 Changed 3 months ago by Don-vip

Ticket #15972 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.