Modify

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#15958 closed defect (fixed)

IllegalArgumentException: MALFORMED at MapPaintStyles.fromSourceEntry

Reported by: geri-oc Owned by: team
Priority: normal Milestone: 18.02
Component: Core mappaint Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start über ICON


What is the expected result?

Beim Laden Fehlermeldung bei -> Bildeinstellungen werden geladen - Abbruchstelle

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-01-28 23:08:56 +0100 (Sun, 28 Jan 2018)
Build-Date:2018-01-28 22:25:44
Revision:13367
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13367 de) Windows Vista 32-Bit
OS Build number: Windows Vista (TM) Home Premium (6002)
Memory Usage: 123 MB / 989 MB (23 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1440x900
Maximum Screen Size: 1440x900

Plugins:
+ FastDraw
+ PicLayer
+ SeaMapEditor
+ buildings_tools
+ measurement
+ public_transport
+ reverter
+ terracer
+ turnlanes
+ turnrestrictions
+ utilsplugin2
+ wikipedia

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://raw.github.com/rurseekatze/OpenRailwayMap/master/josm-presets/de.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Diving&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&preset&zip=1
+ https://raw.github.com/Flacus/Windrad/master/windrad.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DE.zip
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Sport.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PriorityRoad&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_PAC.zip
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_AME.zip

Validator rules:
+ http://www.openrailwaymap.org/validator/de-openrailwaymap.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/CzechRepublicAddressSystem&zip=1

Last errors/warnings:
- W:  Spur juction: Could not get presets icon spur-25.png
- E: Fehler beim Laden des Bildes 'crossover-28.png'
- W:  Crossover: Could not get presets icon crossover-28.png
- E: Fehler beim Laden des Bildes 'milestone.png'
- W:  Milestone: Could not get presets icon milestone.png
- E: Fehler beim Laden des Bildes 'phone-32.png'
- W:  Phone (Railway): Could not get presets icon phone-32.png
- E: Fehler beim Laden des Bildes 'owner-change.svg'
- W:  Change of Operator: Could not get presets icon owner-change.svg
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED. Ursache: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED. Ursache: java.lang.IllegalArgumentException: MALFORMED


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED
	at org.openstreetmap.josm.Main.initialize(Main.java:169)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1013)
	at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:278)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:845)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED
	at java.util.concurrent.FutureTask.report(Unknown Source)
	at java.util.concurrent.FutureTask.get(Unknown Source)
	at org.openstreetmap.josm.Main.initialize(Main.java:162)
	... 3 more
Caused by: java.lang.IllegalArgumentException: MALFORMED
	at java.util.zip.ZipCoder.toString(Unknown Source)
	at java.util.zip.ZipFile.getZipEntry(Unknown Source)
	at java.util.zip.ZipFile.access$900(Unknown Source)
	at java.util.zip.ZipFile$ZipEntryIterator.next(Unknown Source)
	at java.util.zip.ZipFile$ZipEntryIterator.nextElement(Unknown Source)
	at java.util.zip.ZipFile$ZipEntryIterator.nextElement(Unknown Source)
	at org.openstreetmap.josm.io.CachedFile.findZipEntryImpl(CachedFile.java:340)
	at org.openstreetmap.josm.io.CachedFile.findZipEntryPath(CachedFile.java:305)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.fromSourceEntry(MapPaintStyles.java:342)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:307)
	at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initialize(MapPaintPreference.java:188)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:253)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:232)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 16 months ago by Don-vip

Component: CoreCore mappaint
Milestone: 18.02
Summary: JOSM startet mit FehlerIllegalArgumentException: MALFORMED at MapPaintStyles.fromSourceEntry

comment:2 Changed 16 months ago by Don-vip

Ticket #15959 has been marked as a duplicate of this ticket.

comment:3 Changed 16 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13436/josm:

fix #15958 - robustness when loading map paint styles

comment:4 Changed 16 months ago by Don-vip

Ticket #15996 has been marked as a duplicate of this ticket.

comment:5 Changed 16 months ago by Don-vip

Ticket #16028 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.