Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#15905 closed defect (fixed)

JsonParsingException at FieldPapersAddLayerAction.getMetadata

Reported by: anonymous Owned by: mojodna
Priority: normal Milestone:
Component: Plugin fieldpapers Version:
Keywords: template_report github Cc: floscher

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-01-28 23:08:56 +0100 (Sun, 28 Jan 2018)
Build-Date:2018-01-28 22:25:44
Revision:13367
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13367 pl) Windows 10 64-Bit
OS Build number: Windows 10 Home 1709 (16299)
Memory Usage: 297 MB / 989 MB (84 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Plugins:
+ ColumbusCSV (33862)
+ FastDraw (33731)
+ ImproveWay (17)
+ OpeningHoursEditor (33876)
+ PicLayer (34021)
+ SimplifyArea (33918)
+ Tracer2 (33908)
+ apache-commons (33668)
+ buildings_tools (34040)
+ continuosDownload (68)
+ ejml (32680)
+ fieldpapers (v0.4.3)
+ geotools (33958)
+ imagery-xml-bounds (33830)
+ jts (32699)
+ opendata (34019)
+ reverter (34036)
+ terracer (33839)
+ undelete (33980)
+ utilsplugin2 (33991)
+ wikipedia (33993)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Warning: Failed to scan file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' for module information. Skipping.
- E: Handled by bug report queue: javax.json.stream.JsonParsingException: Unexpected char 60 at (line no=1, column no=1, offset=0)
- W: Ostrzeżenie - <html>Nie można odnaleźć informacji o następujących wtyczkach:<ul><li>ImproveWay</li><li>apache-commons</li><li>geotools</li><li>opendata</li><li>jts</li><li>SimplifyArea</li><li>ejml</li><li>reverter</li><li>FastDraw</li><li>continuosDownload</li><li>utilsplugin2</li><li>fieldpapers</li><li>OpeningHoursEditor</li><li>imagery-xml-bounds</li><li>undelete</li><li>buildings_tools</li><li>terracer</li><li>wikipedia</li><li>Tracer2</li><li>ColumbusCSV</li><li>PicLayer</li></ul>Wtyczki nie zostaną wczytane</html>
- W: Warning: Failed to scan file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' for module information. Skipping.
- W: Warning: Failed to scan file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' for module information. Skipping.
- W: Warning: Failed to scan file 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' for module information. Skipping.
- E: Handled by bug report queue: javax.json.stream.JsonParsingException: Unexpected char 60 at (line no=1, column no=1, offset=0)


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
javax.json.stream.JsonParsingException: Unexpected char 60 at (line no=1, column no=1, offset=0)
	at org.glassfish.json.JsonTokenizer.unexpectedChar(JsonTokenizer.java:601)
	at org.glassfish.json.JsonTokenizer.nextToken(JsonTokenizer.java:418)
	at org.glassfish.json.JsonParserImpl$NoneContext.getNextEvent(JsonParserImpl.java:413)
	at org.glassfish.json.JsonParserImpl.next(JsonParserImpl.java:363)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:111)
	at org.openstreetmap.josm.plugins.fieldpapers.FieldPapersAddLayerAction.getMetadata(FieldPapersAddLayerAction.java:115)
	at org.openstreetmap.josm.plugins.fieldpapers.FieldPapersAddLayerAction.openUrl(FieldPapersAddLayerAction.java:70)
	at org.openstreetmap.josm.plugins.fieldpapers.FieldPapersAddLayerAction.actionPerformed(FieldPapersAddLayerAction.java:57)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 3 months ago by stoecker

Component: CorePlugin fieldpapers
Owner: changed from team to mojodna

comment:2 Changed 3 months ago by Don-vip

Summary: Not workingJsonParsingException at FieldPapersAddLayerAction.getMetadata

comment:3 Changed 3 months ago by Don-vip

Cc: floscher added

@floscher: I don't understand how this plugin is maintained. The sources are updated at https://github.com/fieldpapers/josm-fieldpapers but the releases are made in https://github.com/floscher/josm-fieldpapers/releases?

Last edited 3 months ago by Don-vip (previous) (diff)

comment:4 Changed 3 months ago by Don-vip

Keywords: github added

comment:5 Changed 3 months ago by Don-vip

Resolution: fixed
Status: newclosed

PR merged.

comment:6 in reply to:  3 Changed 3 months ago by floscher

Replying to Don-vip:

@floscher: I don't understand how this plugin is maintained. The sources are updated at https://github.com/fieldpapers/josm-fieldpapers but the releases are made in https://github.com/floscher/josm-fieldpapers/releases?

The repository is maintained at https://github.com/fieldpapers/josm-fieldpapers . My fork was only a temporary measure to provide patched releases. Because there were no more releases since then until today, my fork still served the current release. All coming releases will be published at https://github.com/fieldpapers/josm-fieldpapers/releases .
At the moment there is still a small problem with publishing the next release v0.4.4, but that should be resolved pretty soon (see https://github.com/fieldpapers/josm-fieldpapers/issues/11).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain mojodna.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.