Modify

Opened 12 years ago

Closed 12 years ago

#159 closed defect (wontfix)

JOSM aborts with latest Sun JAVA SDK (1.5.0.8, Linux/x86_64/Fedora Core 6/AMD Opteron)

Reported by: brwk@… Owned by: imi
Priority: major Milestone:
Component: unspecified Version:
Keywords: Cc:

Description

% java -jar josm-latest.jar
Exception in thread "main" java.lang.NoClassDefFoundError: org.openstreetmap.josm.Main

at java.lang.Class.initializeClass(libgcj.so.7rh)
at java.lang.Class.initializeClass(libgcj.so.7rh)

Caused by: java.lang.ClassNotFoundException: java.util.concurrent.Executor not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:josm-latest.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}

at java.net.URLClassLoader.findClass(libgcj.so.7rh)
at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
at java.lang.Class.initializeClass(libgcj.so.7rh)
...1 more

%

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by imi

Resolution: wontfix
Status: newclosed

JOSM cannot be run under gnu classpth nor gcj (yet). Install the JRE from Sun, Blackdown or IBM (which are all roughly the same).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain imi.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.