Modify

Opened 5 months ago

Closed 5 months ago

#15899 closed defect (fixed)

Command Line Option --help crashes on Windows

Reported by: Hb--- Owned by: team
Priority: normal Milestone: 18.02
Component: Core Version:
Keywords: windows command regression Cc: bastik

Description (last modified by Don-vip)

The command line java josm-latest.jar --help crashes on MS Windows. It works fine on Ubuntu. A formal bug report was not created. Perhaps something from #15273 ?

C:\Users\<user>\Desktop>java -jar josm-latest.jar  --help
2018-02-09 21:49:42.136 SCHWERWIEGEND: Handled by bug report queue: java.lang.NullPointerException
java.lang.NullPointerException
        at org.openstreetmap.josm.tools.PlatformHookWindows.getDefaultUserDataDirectory(PlatformHookWindows.java:480)
        at org.openstreetmap.josm.gui.MainApplication.getHelp(MainApplication.java:800)
        at org.openstreetmap.josm.gui.MainApplication.showHelp(MainApplication.java:763)
        at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:895)
        at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:278)
        at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:845)

2018-02-09 21:49:42.276 SCHWERWIEGEND: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Ursache: java.lang.NullPointerException
java.util.concurrent.ExecutionException: java.lang.NullPointerException
        at java.util.concurrent.FutureTask.report(Unknown Source)
        at java.util.concurrent.FutureTask.get(Unknown Source)
        at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitAndReturn(GuiHelper.java:265)
        at org.openstreetmap.josm.gui.bugreport.BugReportDialog.showFor(BugReportDialog.java:270)
        at org.openstreetmap.josm.tools.bugreport.BugReportQueue.displayFor(BugReportQueue.java:134)
        at org.openstreetmap.josm.tools.bugreport.BugReportQueue.access$200(BugReportQueue.java:17)
        at org.openstreetmap.josm.tools.bugreport.BugReportQueue$BugReportDisplayRunnable.run(BugReportQueue.java:100)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.addMenuEntry(TextContextualPopupMenu.java:174)
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.addMenuEntries(TextContextualPopupMenu.java:108)
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.attach(TextContextualPopupMenu.java:93)
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.enableMenuFor(TextContextualPopupMenu.java:143)
        at org.openstreetmap.josm.gui.widgets.JosmTextArea.<init>(JosmTextArea.java:90)
        at org.openstreetmap.josm.gui.widgets.JosmTextArea.<init>(JosmTextArea.java:25)
        at org.openstreetmap.josm.gui.bugreport.DebugTextDisplay.<init>(DebugTextDisplay.java:29)
        at org.openstreetmap.josm.gui.bugreport.DebugTextDisplay.<init>(DebugTextDisplay.java:51)
        at org.openstreetmap.josm.gui.bugreport.BugReportDialog.<init>(BugReportDialog.java:92)
        at org.openstreetmap.josm.gui.bugreport.BugReportDialog.lambda$showFor$3(BugReportDialog.java:280)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
        at java.awt.EventQueue.access$500(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)
URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-02-08 01:38:37 +0100 (Thu, 08 Feb 2018)
Build-Date:2018-02-08 02:32:23
Revision:13392
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13392 de) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 462 MB / 3604 MB (298 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1280x1024
Maximum Screen Size: 1280x1024

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (3)

comment:1 Changed 5 months ago by Don-vip

Description: modified (diff)

comment:2 Changed 5 months ago by Don-vip

Keywords: regression added
Milestone: 18.02

comment:3 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13396/josm:

fix #15899 - fix JOSM initialization sequence leading to NPE on Windows when calling --help

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.