Modify

Opened 3 years ago

Closed 3 years ago

#15873 closed defect (duplicate)

ArrayIndexOutOfBoundsException: Coordinate out of bounds! at AreaElement.create

Reported by: wilhelm.tulzer@… Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. When i start the stored file with data this error happaens

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-01-28 23:08:56 +0100 (Sun, 28 Jan 2018)
Build-Date:2018-01-28 22:25:44
Revision:13367
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13367 de) Mac OS X 10.13.3
OS Build number: Mac OS X 10.13.3 (17D47)
Memory Usage: 692 MB / 910 MB (165 MB allocated, but free)
Java version: 1.8.0_161-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 2077808445 1440x900
Maximum Screen Size: 1440x900
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
+ SeaChart (33995)
+ SeaMapEditor (33914)
+ markseen (7)

Tagging presets:
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml

Map paint styles:
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT1_Seamark.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: Coordinate out of bounds!


=== REPORTED CRASH DATA ===
AreaElement#create:
 - env.osm: {Way id=101546663 version=2 VT nodes=[{Node id=1172640624 version=2 V lat=43.8531136,lon=16.0176446}, {Node id=1172639178 version=2 V lat=43.8524472,lon=16.0186669}, {Node id=1172640965 version=1 V lat=43.8518338,lon=16.0179553}, {Node id=3259044679 version=1 V lat=43.8517929,lon=16.0178574}, {Node id=1172638362 version=2 V lat=43.8517987,lon=16.0177332}, {Node id=1172640872 version=2 V lat=43.8522454,lon=16.0168581}, {Node id=1172638251 version=1 V lat=43.8525771,lon=16.0170297}, {Node id=1172640624 version=2 V lat=43.8531136,lon=16.0176446}]}
 - iconRef: IconReference{iconName='https://raw.githubusercontent.com/OpenSeaMap/josm/master/icons/svg/E/E19.svg' source='OpenSeaMap: Seamarks according to INT 1 (IHO standarized symbols)'}
 - fillImage: https://raw.githubusercontent.com/OpenSeaMap/josm/master/icons/svg/E/E19.svg
 - img: BufferedImage@18e16ffe: type = 2 DirectColorModel: rmask=ff0000 gmask=ff00 bmask=ff amask=ff000000 IntegerInterleavedRaster: width = 24 height = 24 #Bands = 4 xOff = 0 yOff = 0 dataOffset[0] 0

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: styled-map-renderer-2 (72) of main
java.lang.ArrayIndexOutOfBoundsException: Coordinate out of bounds!
	at sun.awt.image.IntegerInterleavedRaster.getDataElements(IntegerInterleavedRaster.java:219)
	at java.awt.image.BufferedImage.getRGB(BufferedImage.java:917)
	at org.openstreetmap.josm.gui.mappaint.styleelement.AreaElement.create(AreaElement.java:90)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.generateStyles(ElemStyles.java:375)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getImpl(ElemStyles.java:230)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getStyleCacheWithRange(ElemStyles.java:148)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.get(ElemStyles.java:127)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.add(ComputeStyleListWorker.java:164)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.visit(ComputeStyleListWorker.java:138)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:210)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.acceptDrawable(ComputeStyleListWorker.java:124)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.computeDirectly(ComputeStyleListWorker.java:111)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.compute(ComputeStyleListWorker.java:88)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.compute(ComputeStyleListWorker.java:34)
	at java.util.concurrent.RecursiveTask.exec(RecursiveTask.java:94)
	at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
	at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056)
	at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692)
	at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157)

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Don-vip

Component: CoreCore mappaint
Summary: Error Window when file ist startedArrayIndexOutOfBoundsException: Coordinate out of bounds! at AreaElement.create

comment:2 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15747.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.