Modify

#15821 closed enhancement (fixed)

Should display only one dialog when multiple conflicts exists

Reported by: naoliv Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: conflict Cc:

Description

While reverting a lot of changesets where multiple conflicts exists we can see something like this:

https://i.imgur.com/0QK0FFU.png

Since the dialog basically only has an "Accept" button, JOSM should group all the conflicts and only display a single dialog at the end, with something like "XXXXX conflicts detected in total"

I don't know if it's related with JOSM itself or with the reverter plugins (so I am leaving the component on Core).

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-01-22 00:01:43 +0100 (Mon, 22 Jan 2018)
Revision:13353
Build-Date:2018-01-22 03:24:26
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13353 pt_BR) Linux Debian GNU/Linux testing (buster)
Memory Usage: 858 MB / 7168 MB (428 MB allocated, but free)
Java version: 9.0.1+11-Debian-1, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-9-jre:amd64-9.0.1+11-1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-15
VM arguments: [--add-modules=java.activation,java.se.ee, -Dawt.useSystemAAFontSettings=on]

Plugins:
+ FastDraw (33731)
+ ImportImagePlugin (33563)
+ OpeningHoursEditor (33876)
+ PicLayer (34021)
+ SimplifyArea (33918)
+ apache-commons (33668)
+ buildings_tools (33735)
+ download_along (33710)
+ editgpx (33782)
+ ejml (32680)
+ geojson (73)
+ geotools (33958)
+ jts (32699)
+ log4j (32699)
+ measurement (33760)
+ opendata (34019)
+ pbf (33568)
+ poly (33570)
+ reverter (33865)
+ scripting (30782)
+ tageditor (33806)
+ todo (30303)
+ turnlanes-tagging (260)
+ turnrestrictions (33780)
+ undelete (33980)
+ utilsplugin2 (33991)

Attachments (0)

Change History (3)

comment:1 Changed 18 months ago by Don-vip

Component: CorePlugin reverter
Keywords: conflict added
Owner: changed from team to Upliner

comment:2 Changed 18 months ago by Don-vip

Ticket #15822 has been marked as a duplicate of this ticket.

comment:3 Changed 18 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o34028:34029].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.