Modify

Opened 3 years ago

Closed 3 years ago

#15806 closed defect (duplicate)

DataIntegrityProblemException: Deleted node referenced

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report conflict Cc:

Description

What steps will reproduce the problem?

1.TO UPLOAD OUTSIDE TILE CONFLICT IS REQUIRED TO BE FIXED UPON DELETING BOUNDARY AS BUILDING IS WITHN TH POLYGON ERROR APPEARS

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-12-31 03:09:43 +0100 (Sun, 31 Dec 2017)
Build-Date:2017-12-31 02:33:46
Revision:13265
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13265 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Home 1709 (16299)
Memory Usage: 427 MB / 989 MB (114 MB allocated, but free)
Java version: 1.8.0_112-b15, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768

Dataset consistency test:
[DELETED REFERENCED] {Way id=525489634 version=1 MVT nodes=[{Node id=-49649 version=0 MV lat=16.75304718932347,lon=-93.1378519561887}, {Node id=-49613 version=0 MV lat=16.752867403659042,lon=-93.1378170874715}, {Node id=-49630 version=0 MV lat=16.75288281386552,lon=-93.13789218932394}, {Node id=5112039870 version=1 V lat=16.7526092,lon=-93.1376759}, {Node id=5112039871 version=1 V lat=16.7531122,lon=-93.1375113}, {Node id=5112039872 version=1 V lat=16.7532218,lon=-93.1375596}, {Node id=5112039873 version=1 V lat=16.7532461,lon=-93.1378771}, {Node id=5112039865 version=1 MVD lat=16.75320247345357,lon=-93.13790121779098}]} refers to deleted primitive {Node id=5112039865 version=1 MVD lat=16.75320247345357,lon=-93.13790121779098}


Plugins:
+ CADTools (1007)
+ DirectUpload (33882)
+ areaselector (336)
+ austriaaddresshelper (1511306130)
+ buildings_tools (33735)
+ ejml (32680)
+ imagery_offset_db (33774)
+ log4j (32699)
+ turnrestrictions (33780)

Last errors/warnings:
- E: Error header: Precondition failed: Node 5112039856 is still used by ways 525489633.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 5112039856 is still used by ways 525489633.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 5112039856</strong>. It is still referred to by way 525489633.<br>Please load the way, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution dialogue.</html>
- W: Warning - <html>The data to be uploaded participates in unresolved conflicts of layer 'OSM Data'.<br>You have to resolve them first.</html>
- E: Error header: Precondition failed: Node 5112039865 is still used by ways 525489634,525489634.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 5112039865 is still used by ways 525489634,525489634.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 5112039865</strong>. It is still referred to by way 525489634.<br>Please load the way, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution dialogue.</html>
- W: Warning - <html>The data to be uploaded participates in unresolved conflicts of layer 'OSM Data'.<br>You have to resolve them first.</html>
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=525489634 version=1 MVT nodes=[{Node id=-49649 version=0 MV lat=16.75304718932347,lon=-93.1378519561887}, {Node id=5112039869 version=1 MV lat=16.7530124326891,lon=-93.13778056931152}, {Node id=-49613 version=0 MV lat=16.752867403659042,lon=-93.1378170874715}, {Node id=-49630 version=0 MV lat=16.75288281386552,lon=-93.13789218932394}, {Node id=5112039870 version=1 V lat=16.7526092,lon=-93.1376759}, {Node id=5112039871 version=1 V lat=16.7531122,lon=-93.1375113}, {Node id=5112039872 version=1 V lat=16.7532218,lon=-93.1375596}, {Node id=5112039873 version=1 V lat=16.7532461,lon=-93.1378771}, {Node id=5112039865 version=1 MVD lat=16.75320247345357,lon=-93.13790121779098}]}
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=525489634 version=1 MVT nodes=[{Node id=-49649 version=0 MV lat=16.75304718932347,lon=-93.1378519561887}, {Node id=-49613 version=0 MV lat=16.752867403659042,lon=-93.1378170874715}, {Node id=-49630 version=0 MV lat=16.75288281386552,lon=-93.13789218932394}, {Node id=5112039870 version=1 V lat=16.7526092,lon=-93.1376759}, {Node id=5112039871 version=1 V lat=16.7531122,lon=-93.1375113}, {Node id=5112039872 version=1 V lat=16.7532218,lon=-93.1375596}, {Node id=5112039873 version=1 V lat=16.7532461,lon=-93.1378771}, {Node id=5112039865 version=1 MVD lat=16.75320247345357,lon=-93.13790121779098}]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=525489634 version=1 MVT nodes=[{Node id=-49649 version=0 MV lat=16.75304718932347,lon=-93.1378519561887}, {Node id=-49613 version=0 MV lat=16.752867403659042,lon=-93.1378170874715}, {Node id=-49630 version=0 MV lat=16.75288281386552,lon=-93.13789218932394}, {Node id=5112039870 version=1 V lat=16.7526092,lon=-93.1376759}, {Node id=5112039871 version=1 V lat=16.7531122,lon=-93.1375113}, {Node id=5112039872 version=1 V lat=16.7532218,lon=-93.1375596}, {Node id=5112039873 version=1 V lat=16.7532461,lon=-93.1378771}, {Node id=5112039865 version=1 MVD lat=16.75320247345357,lon=-93.13790121779098}]}
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:600)
	at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:616)
	at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:73)
	at org.openstreetmap.josm.data.osm.DataSet.unlinkNodeFromWays(DataSet.java:999)
	at org.openstreetmap.josm.data.osm.DataSet.unlinkReferencesToPrimitive(DataSet.java:1055)
	at org.openstreetmap.josm.command.conflict.DeletedStateConflictResolveCommand.deleteMy(DeletedStateConflictResolveCommand.java:77)
	at org.openstreetmap.josm.command.conflict.DeletedStateConflictResolveCommand.executeCommand(DeletedStateConflictResolveCommand.java:60)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:69)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:92)
	at org.openstreetmap.josm.gui.dialogs.ConflictResolutionDialog$ApplyResolutionAction.actionPerformed(ConflictResolutionDialog.java:206)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:227)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:227)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1671)
	at java.awt.Component.setVisible(Component.java:1623)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:458)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:254)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.resolve(ConflictDialog.java:208)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog.access$200(ConflictDialog.java:78)
	at org.openstreetmap.josm.gui.dialogs.ConflictDialog$ResolveAction.actionPerformed(ConflictDialog.java:462)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Don-vip

Keywords: conflict added
Summary: POLYGON COMMERCIAL BOUNDARYDataIntegrityProblemException: Deleted node referenced

comment:2 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15460.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.