Modify

#15679 closed defect (duplicate)

IAE: Node is already deleted (DeleteAction)

Reported by: Kathyaus Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report conflict Cc:

Description

What steps will reproduce the problem?

  1. Unknown

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-11-26 14:31:59 +0100 (Sun, 26 Nov 2017)
Build-Date:2017-11-26 13:34:54
Revision:13170
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13170 en_AU) Windows 10 64-Bit
OS Build number: Windows 10 Home 1709 (16299)
Memory Usage: 838 MB / 3611 MB (306 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080
Maximum Screen Size: 1920x1080

Dataset consistency test:
[DELETED REFERENCED] {Way id=524788540 version=1 MVT nodes=[{Node id=5106430006 version=1 V lat=16.750715,lon=-93.1158269}, {Node id=5106430007 version=1 V lat=16.7507064,lon=-93.1157707}, {Node id=5106430005 version=1 VD lat=16.750877,lon=-93.1158028}]} refers to deleted primitive {Node id=5106430005 version=1 VD lat=16.750877,lon=-93.1158028}


Plugins:
+ BuildingGeneralization (16)
+ buildings_tools (33735)
+ contourmerge (1032)
+ imagery_offset_db (33774)
+ measurement (33760)
+ terracer (33839)
+ turnrestrictions (33780)
+ utilsplugin2 (33742)

Last errors/warnings:
- E: Error header: Precondition failed: Node 5106430543 is still used by ways 524788557.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 5106430543 is still used by ways 524788557.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 5106430543</strong>. It is still referred to by way 524788557.<br>Please load the way, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution dialogue.</html>
- E: Error header: Precondition failed: Node 5106430538 is still used by ways 524788554,524788555.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 5106430538 is still used by ways 524788554,524788555.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 5106430538</strong>. It is still referred to by ways [524788554, 524788555].<br>Please load the ways, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution dialogue.</html>
- E: Error header: Precondition failed: Node 5106430005 is still used by ways 524788540,524788540.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 5106430005 is still used by ways 524788540,524788540.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 5106430005</strong>. It is still referred to by way 524788540.<br>Please load the way, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution dialogue.</html>
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Node id=5106430005 version=1 VD lat=16.750877,lon=-93.1158028} is already deleted


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalArgumentException: {Node id=5106430005 version=1 VD lat=16.750877,lon=-93.1158028} is already deleted
	at org.openstreetmap.josm.command.DeleteCommand.executeCommand(DeleteCommand.java:222)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:80)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:69)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:92)
	at org.openstreetmap.josm.actions.mapmode.DeleteAction.doActionPerformed(DeleteAction.java:159)
	at org.openstreetmap.josm.actions.DeleteAction.actionPerformed(DeleteAction.java:74)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 16 months ago by Kathyaus

Trying to delete part of building outside of tile area. Nodes have come up as conflict so need to be resolved before I can upload my changes to data file.

comment:2 Changed 16 months ago by Don-vip

Summary: Unexpected exception occurredIAE: Node is already deleted

comment:3 Changed 16 months ago by Don-vip

Keywords: conflict added

comment:4 Changed 12 months ago by Don-vip

Summary: IAE: Node is already deletedIAE: Node is already deleted (DeleteAction)

comment:5 Changed 12 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9705.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.