Modify

Opened 3 years ago

Closed 3 years ago

#15677 closed defect (fixed)

areaselector plugin: ClassNotFoundException: org.ejml.UtilEjml

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Plugin areaselector Version:
Keywords: Cc:

Description

I was testing the area areaselector plugin with the HSV selection mode enabled:

2017-12-18 02:33:01,011 [AWT-EventQueue-0] INFO : selecting color
2017-12-18 02:33:01,012 [AWT-EventQueue-0] INFO : HSV color: H = 1.168028 S = 0.14444445 V = 180.0
2017-12-18 02:33:01.078 GRAVE: Handled by bug report queue: java.lang.NoClassDefFoundError: org/ejml/UtilEjml. Causa: java.lang.ClassNotFoundException: org.ejml.UtilEjml
java.lang.NoClassDefFoundError: org/ejml/UtilEjml
	at georegression.misc.GrlConstants.<clinit>(GrlConstants.java:51)
	at georegression.metric.UtilAngle.minus(UtilAngle.java:223)
	at georegression.metric.UtilAngle.dist(UtilAngle.java:256)
	at org.openstreetmap.josm.plugins.areaselector.ImageAnalyzer.selectColor(ImageAnalyzer.java:351)
	at org.openstreetmap.josm.plugins.areaselector.ImageAnalyzer.getArea(ImageAnalyzer.java:165)
	at org.openstreetmap.josm.plugins.areaselector.AreaSelectorAction.createArea(AreaSelectorAction.java:192)
	at org.openstreetmap.josm.plugins.areaselector.AreaSelectorAction$1.run(AreaSelectorAction.java:145)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:313)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:764)
	at java.desktop/java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:717)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:711)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:734)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:199)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
Caused by: java.lang.ClassNotFoundException: org.ejml.UtilEjml
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:563)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
	... 21 more

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-12-18 02:36:13 +0100 (Mon, 18 Dec 2017)
Revision:13222
Build-Date:2017-12-18 03:53:26
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13222 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 538 MB / 5120 MB (155 MB allocated, but free)
Java version: 9.0.1+11-Debian-1, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-9-jre:amd64-9.0.1+11-1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [--illegal-access=warn, --add-modules=java.se.ee, -Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (33856)
+ ImportImagePlugin (33563)
+ OpeningHoursEditor (33876)
+ PicLayer (33822)
+ SimplifyArea (33918)
+ apache-commons (33668)
+ areaselector (1505420454)
+ austriaaddresshelper (1511306130)
+ buildings_tools (33735)
+ download_along (33710)
+ editgpx (33782)
+ ejml (32680)
+ geojson (73)
+ geotools (33930)
+ jogl (1.1.0)
+ jts (32699)
+ log4j (32699)
+ measurement (33760)
+ merge-overlap (33848)
+ opendata (33791)
+ photo_geotagging (33878)
+ poly (33570)
+ reverter (33865)
+ tageditor (33806)
+ todo (30303)
+ turnlanes-tagging (260)
+ turnrestrictions (33780)
+ undelete (33835)
+ utilsplugin2 (33742)

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.