Modify

Opened 4 years ago

Closed 4 years ago

#15672 closed defect (duplicate)

Buttons always dissabled in the FixAddresses standalone window

Reported by: javiersanp Owned by: OliverW
Priority: normal Milestone:
Component: Plugin fixaddresses Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download some portion of the map with streets and addresses
  2. Edit some address to intentionally make them wrong (change addr:street or delete it)
  3. Tools menu > Fix unresolved addresses (or Ctrl+Shift+X)

What is the expected result?

When I select some entries in the unresolved address list in the lower-left area, the buttons below (select, guess, apply...) should be enabled

What happens instead?

This buttons are dissabled

Please provide any additional information below. Attach a screenshot if possible.

The plugin work as expected in the toggable dialog attached to the right pannel, showed/hidded with the icon in the left toolbar. The buttons are dissabled in the window accessed from the menu (Ctrl+Shift+X). I spend some time to discover this.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-29 19:52:48 +0100 (Sun, 29 Oct 2017)
Build-Date:2017-10-29 19:11:19
Revision:13053
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13053 es) Linux Ubuntu 17.04
Memory Usage: 426 MB / 850 MB (73 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-2ubuntu1.17.04.3-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u131-b11-2ubuntu1.17.04.3
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (33718)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (1)

Captura de pantalla de 2017-12-16 04-58-15.png (256.0 KB) - added by javiersanp 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by javiersanp

comment:1 Changed 4 years ago by dcapillae

I have the same problem, the buttons always dissabled in the FixAddresses standalone window.

My JOSM version is 13170, running in Debian GNU/Linux 9 (stretch) 32-bit.

Thank you!

comment:2 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14013.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain OliverW.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.