Modify

Opened 12 months ago

Closed 8 months ago

Last modified 2 months ago

#15560 closed enhancement (fixed)

Add compatibility with Java 10

Reported by: Don-vip Owned by: team
Priority: normal Milestone: 18.03
Component: Core Version:
Keywords: java10 Cc:

Description (last modified by Don-vip)

Follow-up of #11924.
Unlike Java 9, Java 10 will be far less disruptive.
The code freeze will start on 14th December, very soon with the new release cycle.

See #16047 for Java 11 compatibility.

Attachments (1)

hurray.PNG (2.9 KB) - added by Don-vip 8 months ago.

Download all attachments as: .zip

Change History (36)

comment:1 Changed 12 months ago by Don-vip

In 13073/josm:

see #11924 - see #15560 - support jdk10+ in build.xml, update to proguard 6.0beta1 and error_prone 2.1.2

comment:2 Changed 12 months ago by Don-vip

In 13076/josm:

see #15560 - fix javadoc warnings with recent JDKs

comment:3 Changed 12 months ago by Don-vip

In 13077/josm:

see #15560 - fix javadoc warning with recent JDKs

comment:4 Changed 12 months ago by Don-vip

In 13079/josm:

see #15560 - EqualsVerifier does not work with newer Java versions -> disable tests automatically in this case
Workaround to https://github.com/jqno/equalsverifier/issues/177 / https://github.com/raphw/byte-buddy/issues/370
Inspired by https://issues.apache.org/jira/browse/SOLR-11606

comment:5 Changed 12 months ago by Don-vip

In 13096/josm:

see #15560 - add additionalCoverage optional build parameter to record coverage of classes outside of JOSM (to cover JDK EA classes)

comment:6 Changed 12 months ago by Don-vip

In 13097/josm:

see #15560 - add jacoco.inclbootstrapclasses and jacoco.inclnolocationclasses optional build parameters to record coverage of classes outside of JOSM (to cover JDK EA classes)

comment:7 Changed 12 months ago by Don-vip

In 13103/josm:

see #15560 - repair coverage, fix typo, increase integration test timeout

comment:8 Changed 12 months ago by Don-vip

In 13110/josm:

see #15560 - update to equalsverifier 2.4 (support of Java 10)

comment:9 Changed 11 months ago by Don-vip

Milestone: 17.1218.01

Same problem than with Java 9, ASM has not yet released a compatible version, this causes jacoco to break.

Last edited 10 months ago by Don-vip (previous) (diff)

comment:10 Changed 10 months ago by Don-vip

In 13305/josm:

see #15560 - custom version of jacoco 0.8.1-SNAPSHOT (8685ca83dd562f3df9d2c8221ed5b928b36ebf62 + patch) + asm 6.1-beta (58b93c69)
see https://github.com/jacoco/jacoco/issues/629#issuecomment-356136388

comment:11 Changed 10 months ago by Don-vip

In 13306/josm:

see #15560 - Double.Double() is deprecated

comment:12 Changed 10 months ago by Don-vip

In 13342/josm:

see #15560 - Update to equalsverifier 2.4.2 (see https://github.com/jqno/equalsverifier/issues/183)

comment:13 Changed 10 months ago by Don-vip

Milestone: 18.0118.02

Still waiting for ASM, as usual...

Last edited 10 months ago by Don-vip (previous) (diff)

comment:14 Changed 9 months ago by Don-vip

Milestone: 18.0218.03

comment:15 Changed 9 months ago by Don-vip

javabug:8194955 => We have now a javadoc warning: You have not specified the version of HTML to use.

Last edited 9 months ago by Don-vip (previous) (diff)

comment:16 Changed 9 months ago by Don-vip

In 13491/josm:

see #11924, see #15560, see #16048 - explicitly generate HTML4 javadoc until all errors/warnings are fixed

comment:17 Changed 9 months ago by Don-vip

In 13492/josm:

see #15560, see #16047 - disable error_prone on Java 10+, see https://github.com/google/error-prone/issues/860

comment:18 Changed 9 months ago by Don-vip

In 13493/josm:

see #11924, see #15560, see #16048 - tt HTML tag is deprecated in HTML5: use code instead

comment:19 Changed 9 months ago by Don-vip

In 13494/josm:

see #11924, see #15560, fix #16048: Generate HTML5 javadoc with Java 9/10/11

  • name HTML attribute is deprecated in HTML5: use id instead

comment:20 Changed 9 months ago by Don-vip

javabug:8183518 => New deprecation warning: getMenuShortcutKeyMask() in Toolkit has been deprecated

comment:21 Changed 9 months ago by Don-vip

In 13504/josm:

see #11924, see #15560 - fix deprecation warning with Java 10

comment:22 Changed 8 months ago by Don-vip

In 13519/josm:

see #15560 - upgrade to equalsverifier-2.4.4 (contains ASM 6.1 for Java 10 compatibility)

comment:23 Changed 8 months ago by Don-vip

We now have a single test failing with Java 10: ProjectionRegressionTest.testNonRegression. Again tiny differences in numeric computations, like in #11889 / #13387 with Java 9.

comment:24 Changed 8 months ago by Don-vip

OK it's just because Utils.getJavaVersion() fails to detect two-digits major version numbers!

comment:25 Changed 8 months ago by Don-vip

In 13520/josm:

see #15560 - fix detection of Java version >= 10

Changed 8 months ago by Don-vip

Attachment: hurray.PNG added

comment:26 Changed 8 months ago by Don-vip

Resolution: fixed
Status: newclosed

Build stable \o/


comment:27 Changed 8 months ago by Klumbumbus

👍

comment:28 Changed 8 months ago by Don-vip

In 13550/josm:

see #15560 - update to jacoco 0.8.1

comment:29 Changed 7 months ago by Don-vip

In 13695/josm:

see #15560, see #16047 - detect java 10/11 packages

comment:30 Changed 7 months ago by Don-vip

In 13700/josm:

see #15560, see #16047 - detect java 10/11 packages

comment:31 Changed 6 months ago by Don-vip

In 13818/josm:

see #15560 - fix javadoc warnings with Java 10

comment:32 Changed 4 months ago by Don-vip

Description: modified (diff)

comment:33 Changed 3 months ago by Don-vip

comment:34 Changed 2 months ago by Don-vip

In 14244/josm:

see #11924, see #15560, see #16047, see #16682 - fixes to make work proguard (OK) and animal_sniffer (still KO) with Java 9+

comment:35 Changed 2 months ago by Don-vip

In 14245/josm:

see #11924, see #15560, see #16047, see #16682 - fixes to make work animal_sniffer (OK) with Java 9+

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.