Modify

Opened 6 months ago

Closed 4 months ago

Last modified 4 months ago

#15554 closed defect (fixed)

plugin(s) crashed on restart after updating

Reported by: rickmastfan67 Owned by: team
Priority: normal Milestone: 18.01
Component: Core Version: latest
Keywords: plugin classloader Cc:

Description

Just had the 'tageditor' plugin crash on the next restart after I had just updated it. The next restart after that, there wasn't any problems. Still thought I'd post about this. Don't think my prefernces are broken, but who knows.

Seems that #15200 might be related, as the crash location looks to be identical, even though it's a totally different plugin.

2017-11-15 01:26:47.708 SEVERE: org.openstreetmap.josm.plugins.PluginException:
An error occurred in plugin tageditor. Cause: java.lang.ClassNotFoundException:
org.openstreetmap.josm.plugins.tageditor.TagEditorPlugin
org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin tageditor
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:347)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:783)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:870)
        at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:909)
        at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:1259)
        at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1039)
        at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:283)
        at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:867)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.tageditor.TagEditorPlugin
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:345)
        ... 7 more

2017-11-15 01:26:47.723 WARNING: Disable plugin - <html>Could not load plugin tageditor because the plugin<br>main class 'org.openstreetmap.josm.plugins.tageditor.TagEditorPlugin' was not found.<br>Delete from preferences?</html>
URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-11-12 21:14:52 +0100 (Sun, 12 Nov 2017)
Build-Date:2017-11-12 20:24:34
Revision:13119
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13119 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 446 MB / 1820 MB (238 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ OpeningHoursEditor (33185)
+ buildings_tools (33735)
+ measurement (33760)
+ reverter (33572)
+ tageditor (33806)
+ turnlanes-tagging (254)
+ turnrestrictions (33780)
+ undelete (33480)
+ utilsplugin2 (33742)

Attachments (0)

Change History (7)

comment:1 Changed 6 months ago by Don-vip

Component: Plugin tageditorCore
Keywords: plugin classloader added
Priority: minornormal

Looks like a bug of the plugin classloader right after an update

comment:2 Changed 6 months ago by rickmastfan67

I did have a feeling that it could have been a bug in 'core'. Have had this crash with other plugins on the first restart after updating any plugin for awhile. Had thought it was possibly my profile, hence why I hadn't reported it till now.

comment:3 Changed 6 months ago by rickmastfan67

Just had it happen again for 4 different plugins when updating them tonight. However, the error placement was a tad different indicating a few lines had been removed in the 'pluginhandler' in core.

Still, here's the crash info from the command line based off JOSM r13174.

2017-11-29 00:12:42.590 SEVERE: org.openstreetmap.josm.plugins.PluginException:
An error occurred in plugin turnlanes-tagging. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.turnlanestagging.TurnLanesTaggingPlugin
org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin turnlanes-tagging
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:347)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:770)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:857)
        at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:896)
        at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:1240)
        at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1020)
        at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:282)
        at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:849)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.turnlanestagging.TurnLanesTaggingPlugin
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:345)
        ... 7 more

comment:4 Changed 5 months ago by rickmastfan67

Summary: tageditor plugin crashed on restart after updatingplugin(s) crashed on restart after updating

Still happening with r13275. Also, here's an updated crash log, as the locations seemed to move slightly again due to other edits in the files.

2018-01-07 06:08:32.926 SEVERE: org.openstreetmap.josm.plugins.PluginException:
An error occurred in plugin undelete. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.undelete.Undelete
org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin undelete
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:348)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:770)
        at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:857)
        at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:896)
        at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:1237)
        at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1017)
        at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:279)
        at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:846)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.undelete.Undelete
        at java.net.URLClassLoader.findClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Unknown Source)
        at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:346)
        ... 7 more

comment:5 Changed 4 months ago by Don-vip

Milestone: 18.01

comment:6 Changed 4 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13294/josm:

fix #15554 - fix plugin classloader after plugin update

comment:7 Changed 4 months ago by rickmastfan67

Can confirm that it's fixed. :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.