Modify

Opened 4 years ago

Closed 2 years ago

#15426 closed defect (duplicate)

ConcurrentModificationException in MapillaryWalkAction

Reported by: Captain47 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by Don-vip)

blocage lors du chargement de JOSM

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-03 21:43:00 +0200 (Tue, 03 Oct 2017)
Build-Date:2017-10-03 19:50:21
Revision:12921
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12921 fr) Linux Ubuntu 16.04.3 LTS
Memory Usage: 288 MB / 448 MB (122 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11, Oracle Corporation, OpenJDK Server VM
Screen: :0.0 1280x800
Maximum Screen Size: 1280x800
Java package: openjdk-8-jre:i386-8u131-b11-2ubuntu1.16.04.3
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
+ FastDraw
+ Mapillary
+ apache-commons (33668)
+ apache-http (32699)
+ ejml (32680)
+ geochat
+ geotools (33380)
+ jts (32699)
+ opendata (33617)
+ pdfimport
+ print
+ utilsplugin2 (33704)
+ wikipedia

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/caravan_site&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/FR.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Avertissement: le scan du fichier 'site-svn.openstreetmap.org-_applications_editors_josm_plugins_opendata_modules.txt' pour le module d'information a échoué. Action ignorée.
- E: Handled by bug report queue: java.lang.ExceptionInInitializerError. Cause : java.util.ConcurrentModificationException
- W: Unable to detect current tested version of JOSM:: java.lang.NumberFormatException: For input string: "<html>12921


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.ExceptionInInitializerError
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:348)
	at org.openstreetmap.josm.plugins.PluginInformation.loadClass(PluginInformation.java:345)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:783)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:870)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:909)
	at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:1203)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:1026)
	at org.openstreetmap.josm.gui.MainApplication$2.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:860)
Caused by: java.util.ConcurrentModificationException
	at java.util.HashMap$HashIterator.nextNode(HashMap.java:1437)
	at java.util.HashMap$KeyIterator.next(HashMap.java:1461)
	at org.openstreetmap.josm.tools.ImageProvider.getImageUrl(ImageProvider.java:1149)
	at org.openstreetmap.josm.tools.ImageProvider.getImageUrl(ImageProvider.java:1200)
	at org.openstreetmap.josm.tools.ImageProvider.getIfAvailableImpl(ImageProvider.java:914)
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:671)
	at org.openstreetmap.josm.actions.JosmAction.<init>(JosmAction.java:83)
	at org.openstreetmap.josm.plugins.mapillary.actions.MapillaryWalkAction.<init>(MapillaryWalkAction.java:41)
	at org.openstreetmap.josm.plugins.mapillary.MapillaryPlugin.<clinit>(MapillaryPlugin.java:57)
	... 10 more

=== RUNNING THREADS ===
Thread: Java2D Disposer (13) of system
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:143)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:164)
sun.java2d.Disposer.run(Disposer.java:148)
java.lang.Thread.run(Thread.java:748)

Thread: AWT-Shutdown (18) of system
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Object.java:502)
sun.awt.AWTAutoShutdown.run(AWTAutoShutdown.java:295)
java.lang.Thread.run(Thread.java:748)

Thread: Thread-7 (33)
java.lang.Class.forName0(Native Method)
java.lang.Class.forName(Class.java:348)
org.openstreetmap.josm.plugins.opendata.core.modules.ModuleInformation.loadClass(ModuleInformation.java:245)
org.openstreetmap.josm.plugins.opendata.core.modules.ModuleHandler.loadModule(ModuleHandler.java:232)
org.openstreetmap.josm.plugins.opendata.core.modules.ModuleHandler.loadModules(ModuleHandler.java:291)
org.openstreetmap.josm.plugins.opendata.OdPlugin.loadModules(OdPlugin.java:195)
org.openstreetmap.josm.plugins.opendata.OdPlugin.lambda$new$1(OdPlugin.java:84)
org.openstreetmap.josm.plugins.opendata.OdPlugin$$Lambda$194/21376571.run(Unknown Source)
java.lang.Thread.run(Thread.java:748)

Thread: Weak reference cleaner (21) of main
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:143)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:164)
org.openstreetmap.josm.tools.ListenableWeakReference.clean(ListenableWeakReference.java:60)
org.openstreetmap.josm.tools.ListenableWeakReference$$Lambda$95/9915973.run(Unknown Source)
java.lang.Thread.run(Thread.java:748)

Thread: Finalizer (3) of system
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:143)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:164)
java.lang.ref.Finalizer$FinalizerThread.run(Finalizer.java:209)

Thread: AWT-EventQueue-0 (17) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(LockSupport.java:175)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2039)
java.awt.EventQueue.getNextEvent(EventQueue.java:554)
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:170)
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Thread: Nashorn AST Serializer (31) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:215)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(AbstractQueuedSynchronizer.java:2078)
java.util.concurrent.LinkedBlockingDeque.pollFirst(LinkedBlockingDeque.java:522)
java.util.concurrent.LinkedBlockingDeque.poll(LinkedBlockingDeque.java:684)
java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1073)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1134)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

Thread: main (1)
Stacktrace see above.

Thread: WeakCollectionCleaner (32) of main
java.lang.Object.wait(Native Method)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:143)
java.lang.ref.ReferenceQueue.remove(ReferenceQueue.java:164)
org.geotools.util.WeakCollectionCleaner.run(WeakCollectionCleaner.java:77)

Thread: Thread-1 (9) of main
sun.nio.fs.LinuxWatchService.poll(Native Method)
sun.nio.fs.LinuxWatchService.access$600(LinuxWatchService.java:47)
sun.nio.fs.LinuxWatchService$Poller.run(LinuxWatchService.java:314)
java.lang.Thread.run(Thread.java:748)

Thread: File Watcher (10) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(LockSupport.java:175)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2039)
java.util.concurrent.LinkedBlockingDeque.takeFirst(LinkedBlockingDeque.java:492)
java.util.concurrent.LinkedBlockingDeque.take(LinkedBlockingDeque.java:680)
sun.nio.fs.AbstractWatchService.take(AbstractWatchService.java:118)
org.openstreetmap.josm.io.FileWatcher.processEvents(FileWatcher.java:135)
org.openstreetmap.josm.io.FileWatcher$$Lambda$4/26282045.run(Unknown Source)
java.lang.Thread.run(Thread.java:748)

Thread: main-init-1 (25)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.jj_3R_24(MapCSSParser.java:2699)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.jj_3R_51(MapCSSParser.java:2668)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.jj_3R_28(MapCSSParser.java:2658)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.jj_3_8(MapCSSParser.java:2885)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.jj_2_8(MapCSSParser.java:2242)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.simple_key_value_condition(MapCSSParser.java:1409)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.condition(MapCSSParser.java:1174)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.child_selector(MapCSSParser.java:997)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.selectors(MapCSSParser.java:927)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.rule(MapCSSParser.java:903)
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.sheet(MapCSSParser.java:887)
org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.readMapCSS(MapCSSTagChecker.java:374)
org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.addMapCSS(MapCSSTagChecker.java:735)
org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.initialize(MapCSSTagChecker.java:762)
org.openstreetmap.josm.data.validation.OsmValidator.initializeTests(OsmValidator.java:384)
org.openstreetmap.josm.data.validation.OsmValidator.initializeTests(OsmValidator.java:367)
org.openstreetmap.josm.gui.MainApplication$$Lambda$172/28789448.run(Unknown Source)
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
java.util.concurrent.FutureTask.run(FutureTask.java:266)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

Thread: image-fetcher-0 (27) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(LockSupport.java:175)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2039)
java.util.concurrent.LinkedBlockingQueue.take(LinkedBlockingQueue.java:442)
java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1074)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1134)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

Thread: GT authority factory disposer (30) of main
java.lang.Object.wait(Native Method)
java.util.TimerThread.mainLoop(Timer.java:552)
java.util.TimerThread.run(Timer.java:505)

Thread: Reference Handler (2) of system
java.lang.Object.wait(Native Method)
java.lang.Object.wait(Object.java:502)
java.lang.ref.Reference.tryHandlePending(Reference.java:191)
java.lang.ref.Reference$ReferenceHandler.run(Reference.java:153)

Thread: AWT-XAWT (16) of system
sun.awt.X11.XToolkit.waitForEvents(Native Method)
sun.awt.X11.XToolkit.run(XToolkit.java:568)
sun.awt.X11.XToolkit.run(XToolkit.java:532)
java.lang.Thread.run(Thread.java:748)

Thread: JCS-ElementEventQueue-Thread-5 (29) of main
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.park(LockSupport.java:175)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2039)
java.util.concurrent.LinkedBlockingQueue.take(LinkedBlockingQueue.java:442)
java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1074)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1134)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

Thread: Signal Dispatcher (4) of system

Thread: TimerQueue (20) of system
sun.misc.Unsafe.park(Native Method)
java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:215)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.awaitNanos(AbstractQueuedSynchronizer.java:2078)
java.util.concurrent.DelayQueue.take(DelayQueue.java:223)
javax.swing.TimerQueue.run(TimerQueue.java:174)
java.lang.Thread.run(Thread.java:748)

Thread: pool-1-thread-1 (34)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.checkInterruptWhileWaiting(AbstractQueuedSynchronizer.java:2003)
java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2040)
java.util.concurrent.LinkedBlockingQueue.take(LinkedBlockingQueue.java:442)
java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1074)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1134)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin mapillary
Description: modified (diff)
Owner: changed from team to floscher
Summary: blocage lors du chargement de JOSMConcurrentModificationException in MapillaryWalkAction

comment:2 Changed 2 years ago by Don-vip

Component: Plugin mapillaryCore
Owner: changed from floscher to team
Resolution: duplicate
Status: newclosed

Closed as duplicate of #17068.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.