Modify

#15341 closed enhancement (fixed)

Display the line number of wrong MapCSS rule

Reported by: naoliv Owned by: team
Priority: normal Milestone: 17.09
Component: Core validator Version:
Keywords: mapcss Cc:

Description

While writing some local rules I was seeing this in JOSM:

2017-09-21 10:36:19.611 INFORMAÇÕES: Source Brasil has been modified. Reloading it...
2017-09-21 10:36:19.628 GRAVE: Cannot add MapCss rule: java.lang.IllegalArgumentException: Unexpected '='. Please only specify the key to remove!

It took a while to find that I was using a wrong fixRemove: "key=value";

Could JOSM say, if possible, the line number where the problem is?

JOSM:

Build-Date:2017-09-21 09:18:11
Revision:12882
Is-Local-Build:true

Identification: JOSM/1.5 (12882 SVN pt_BR) Linux Debian GNU/Linux testing (buster)
Memory Usage: 914 MB / 6372 MB (492 MB allocated, but free)
Java version: 1.8.0_144-8u144-b01-1-b01, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-8-jre:amd64-8u144-b01-1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Attachments (0)

Change History (2)

comment:1 Changed 18 months ago by Don-vip

Keywords: mapcss added
Milestone: 17.09

not possible to include the line, but at least we can include the mapCSS directive.

comment:2 Changed 18 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12883/josm:

fix #15341 - better error message

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.