Modify

Opened 5 years ago

Closed 5 years ago

#15339 closed defect (duplicate)

Shift-r shortcut does not work as expected

Reported by: AlaskaDave Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Create an object and add tags
  2. Create a new object and press Shift-r
  3. Tags are not copied unless and until you have clicked on the new object after committing it to JOSM

What is the expected result?

Expect the tagging of the newly created object to match that of the previous object that had the focus of the editor.

What happens instead?

JOSM tags the new object with the tags of the object last touched prior to creation of the new one

Please provide any additional information below. Attach a screenshot if possible.

Tags are not copied unless and until you have clicked on the new object after first committing it to JOSM. This requires returning to the object and clicking on it a second time.

If this new behaviour is not a bug, then I implore you to return to the "old method"

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Build-Date:2017-09-02 20:53:16
Revision:12712
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12712 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 618 MB / 910 MB (57 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ DirectDownload (33160)
+ DirectUpload (33182)
+ ElevationProfile (33551)
+ FastDraw (33583)
+ InfoMode (33004)
+ OpeningHoursEditor (33185)
+ SeaMapEditor (33054)
+ apache-commons (33517)
+ apache-http (32699)
+ buildings_tools (33004)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geotools (33380)
+ imagery_offset_db (33547)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ opendata (33553)
+ osm-obj-info (1484152384)
+ photo_geotagging (33494)
+ rasterfilters (33269)
+ reltoolbox (33530)
+ tag2link (33382)
+ tageditor (33579)
+ todo (30301)
+ turnrestrictions (33537)
+ utilsplugin2 (33579)
+ wikipedia (33541)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/caravan_site&zip=1
+ %UserProfile%\Dropbox\GPS Files\Ways.xml
+ %UserProfile%\Dropbox\GPS Files\Bbl_Fuel.xml
+ %UserProfile%\Dropbox\GPS Files\Benchmark.xml
+ %UserProfile%\Dropbox\GPS Files\BorC.xml
+ %UserProfile%\Dropbox\GPS Files\Bridge.xml
+ %UserProfile%\Dropbox\GPS Files\CoinOp_Fuel.xml
+ %UserProfile%\Dropbox\GPS Files\Hamlet.xml
+ %UserProfile%\Dropbox\GPS Files\Land-Natural.xml
+ %UserProfile%\Dropbox\GPS Files\Milemarker.xml
+ %UserProfile%\Dropbox\GPS Files\NWR.xml
+ %UserProfile%\Dropbox\GPS Files\Ponds.xml
+ %UserProfile%\Dropbox\GPS Files\ResArea.xml
+ %UserProfile%\Dropbox\GPS Files\ResHwy.xml
+ %UserProfile%\Dropbox\GPS Files\Service.xml
+ %UserProfile%\Dropbox\GPS Files\Stream.xml
+ %UserProfile%\Dropbox\GPS Files\tennis.xml
+ %UserProfile%\Dropbox\GPS Files\UnclassHwy.xml
+ %UserProfile%\Dropbox\GPS Files\Wat.xml
+ %UserProfile%\Dropbox\GPS Files\Waters.xml
+ %UserProfile%\Dropbox\GPS Files\wlan.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ %UserProfile%\Dropbox\GPS Files\address.xml
+ %UserProfile%\Dropbox\GPS Files\Std_Fuel.xml
+ %UserProfile%\Dropbox\GPS Files\Daves-Misc.xml
+ http://code.osm-tools.org/latest/josm-thai-presets.zip
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ %UserProfile%\Dropbox\GPS Files\hydrant.xml
+ %UserProfile%\Dropbox\GPS Files\TAP Service.xml

Last errors/warnings:
- W: java.net.UnknownHostException: server.arcgisonline.com
- W: java.net.UnknownHostException: services.arcgisonline.com
- W: java.net.UnknownHostException: server.arcgisonline.com
- W: java.net.UnknownHostException: server.arcgisonline.com
- W: java.net.UnknownHostException: server.arcgisonline.com
- W: java.net.UnknownHostException: server.arcgisonline.com
- W: java.net.UnknownHostException: services.arcgisonline.com
- W: java.net.UnknownHostException: services.arcgisonline.com
- W: java.net.UnknownHostException: services.arcgisonline.com
- W: java.net.UnknownHostException: server.arcgisonline.com

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Component: CorePlugin utilsplugin2

comment:2 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14862.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.