Modify

Opened 5 years ago

Closed 5 years ago

#15336 closed defect (duplicate)

Adding a (certain type of) barrier on a highway causes an unexpected exception

Reported by: AdVerburg Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report java9 javabug Cc:

Description

What steps will reproduce the problem?

  1. select a node on a highway
  2. in the "Preset group Barriers / Highways" click "Block" OR "Border Control point" OR "Cattle grid" OR "Cycle Barrier" OR "Spikes",

(on "Bollard", "Bus Trap", "Toll Boot" it gives no alarm.)

What is the expected result?

a dialog to insert additional data, and insertion of that type of barrier on the node.

What happens instead?

This unexpected exception.

Please provide any additional information below. Attach a screenshot if possible.

After twice (2x) clicking "Ignore this error" the dialog and insertion goes well.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Revision:12712
Build-Date:2017-09-02 20:53:16
URL:http://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (12712 en_GB) Linux openSUSE Tumbleweed
Memory Usage: 386 MB / 1974 MB (94 MB allocated, but free)
Java version: 9-internal+0-adhoc.abuild.jdk9-b656dea9398e, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-9-jre:package openjdk-9-jre is not installed
Dataset consistency test: No problems found

Plugins:
+ DirectDownload (33160)
+ Mapillary (v1.5.7)
+ PicLayer (33385)
+ SeaChart (33222)
+ SeaMapEditor (33054)
+ apache-commons (33517)
+ apache-http (32699)
+ buildings_tools (33004)
+ editgpx (33004)
+ ejml (32680)
+ graphview (33004)
+ jts (32699)
+ log4j (32699)
+ measurement (33088)
+ osmarender (33004)
+ pdfimport (33579)
+ public_transport (33166)
+ reverter (33572)
+ tageditor (33579)
+ turnlanes (33294)
+ turnlanes-tagging (254)
+ turnrestrictions (33537)
+ utilsplugin2 (33579)

Tagging presets:
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Sport.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/OpenSeaMap_bridge&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ http://mijndev.openstreetmap.nl/~allroads/JOSM/Presets/NL-Fiets.zip

Map paint styles:
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT1_Seamark.mapcss
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/CEVNI_MapCSS.mapcss
+ http://duinoord.home.xs4all.nl/OSM/JOSM/NL_traffic_signs/Styles_Traffic_signs-style.mapcss
- http://mijndev.openstreetmap.nl/~allroads/JOSM/Styles/Road_Extended_JOSM_style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Validator rules:
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Seamark.validator.mapcss

Last errors/warnings:
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
- E: Handled by bug report queue: java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.ClassCastException: org.openstreetmap.josm.gui.widgets.QuadStateCheckBox$QuadStateDecorator cannot be cast to java.desktop/javax.swing.JToggleButton$ToggleButtonModel
	at java.desktop/javax.swing.LayoutFocusTraversalPolicy.accept(LayoutFocusTraversalPolicy.java:243)
	at java.desktop/javax.swing.SortingFocusTraversalPolicy.getFirstComponent(SortingFocusTraversalPolicy.java:492)
	at java.desktop/javax.swing.LayoutFocusTraversalPolicy.getFirstComponent(LayoutFocusTraversalPolicy.java:167)
	at java.desktop/javax.swing.DefaultFocusManager.getFirstComponent(DefaultFocusManager.java:142)
	at java.desktop/javax.swing.LegacyGlueFocusTraversalPolicy.getFirstComponent(LegacyGlueFocusTraversalPolicy.java:133)
	at java.desktop/javax.swing.LegacyGlueFocusTraversalPolicy.getDefaultComponent(LegacyGlueFocusTraversalPolicy.java:151)
	at java.desktop/java.awt.FocusTraversalPolicy.getInitialComponent(FocusTraversalPolicy.java:169)
	at java.desktop/java.awt.Window.getMostRecentFocusOwner(Window.java:2355)
	at java.desktop/java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:746)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:4842)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2317)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2758)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4793)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:766)
	at java.desktop/java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:717)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:711)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:99)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:739)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:737)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:736)
	at java.desktop/java.awt.SequencedEvent.dispatch(SequencedEvent.java:132)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:764)
	at java.desktop/java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:717)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:711)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:99)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:739)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:737)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:736)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:199)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:117)
	at java.desktop/java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:190)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:235)
	at java.desktop/java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:233)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.desktop/java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:233)
	at java.desktop/java.awt.Dialog.show(Dialog.java:1070)
	at java.desktop/java.awt.Component.show(Component.java:1669)
	at java.desktop/java.awt.Component.setVisible(Component.java:1616)
	at java.desktop/java.awt.Window.setVisible(Window.java:1017)
	at java.desktop/java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:458)
	at org.openstreetmap.josm.gui.ExtendedDialog.showDialog(ExtendedDialog.java:254)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPreset$PresetDialog.<init>(TaggingPreset.java:456)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPreset.showDialog(TaggingPreset.java:494)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPreset.actionPerformed(TaggingPreset.java:392)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.AbstractButton.doClick(AbstractButton.java:369)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:980)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1024)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6578)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3343)
	at java.desktop/java.awt.Component.processEvent(Component.java:6343)
	at java.desktop/java.awt.Container.processEvent(Container.java:2259)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:4961)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2317)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4793)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4539)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4480)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2303)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2758)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4793)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:766)
	at java.desktop/java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:717)
	at java.desktop/java.awt.EventQueue$3.run(EventQueue.java:711)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:99)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:739)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:737)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:89)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:736)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:199)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Don-vip

Keywords: java9 javabug added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #15294.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.