Modify

#15251 closed defect (duplicate)

Some deprecation warnings while compiling JOSM

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc: bastiK, michael2402

Description

Sorry if they are already known, but while compiling JOSM it's possible to see:

    [javac] /tmp/a/josm/src/org/openstreetmap/josm/data/UndoRedoHandler.java:179: warning: [deprecation] fireSelectionChanged() in DataSet has been deprecated
    [javac]             ds.fireSelectionChanged();
    [javac]               ^
    [javac] /tmp/a/josm/src/org/openstreetmap/josm/data/osm/Node.java:109: warning: [deprecation] getEastNorth() in ILatLon has been deprecated
    [javac]     public EastNorth getEastNorth() {
    [javac]                      ^
    [javac] 2 warnings

Attachments (0)

Change History (3)

comment:1 Changed 21 months ago by Don-vip

Cc: bastiK michael2402 added
Milestone: 17.09
Type: enhancementdefect

comment:2 Changed 21 months ago by bastiK

In 12753/josm:

see #15251 - suppress (unwarranted) deprecation warning

comment:3 Changed 20 months ago by Don-vip

Milestone: 17.09
Resolution: duplicate
Status: newclosed

Closed as duplicate of #14120.
The last warning is a duplicate of #14120

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.