Modify

Opened 4 years ago

Closed 4 years ago

#14927 closed defect (duplicate)

utilsplugin2: Shift+R does not copy "last changed" tags

Reported by: MKnight Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Mark an empty node
  2. add bla=blubb
  3. Mark another Node
  4. Press Shift+R

What is the expected result?

selected node should get bla=blubb

What happens instead?

selected Node gets Tags from second selected Object

(Tested additional in 11817, there it was working as expected)

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 de) Windows 7 64-Bit
OS Build number: Windows 7 Professional null (7601)
Memory Usage: 493 MB / 1200 MB (207 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768, \Display1 1280x1024
Maximum Screen Size: 1366x1024
Program arguments: [de-josm-kreise.joz]
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (11)
+ CustomizePublicTransportStop (0.4)
+ Mapillary (v1.5.3)
+ OpeningHoursEditor (33185)
+ PicLayer (33148)
+ RoadSigns (33204)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ continuosDownload (53)
+ download_along (32946)
+ ejml (32680)
+ geochat (33088)
+ geojson (52)
+ geotools (33338)
+ jogl (1.0.46)
+ jts (32699)
+ kendzi3d (1.0.195)
+ kendzi3d-resources (0.0.1)
+ log4j (32699)
+ measurement (33088)
+ opendata (33356)
+ pbf (33241)
+ public_transport (33166)
+ reltoolbox (33311)
+ reverter (33088)
+ scripting (30765)
+ tag2link (33035)
+ tageditor (33021)
+ terracer (33088)
+ turnlanes (33294)
+ turnlanes-tagging (254)
+ turnrestrictions (33088)
+ undelete (33263)
+ utilsplugin2 (33328)
+ waydownloader (33167)
+ wikipedia (33288)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Maxspeed-zones&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ http://www.country-linedance.de/daten/Verkehrszeichen-vorlage.zip
+ https://raw.github.com/Flacus/Windrad/master/windrad.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NewParkingFeatures&style&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
+ C:\OSm\JOSM\osmic-josm-style-master\osmic.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ C:\OSm\JOSM\eigene-style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Landcover&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ShowID&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1

Last errors/warnings:
- W: Unable to convert property text-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property symbol-stroke-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property text-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property symbol-stroke-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property text-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property symbol-stroke-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property text-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property symbol-stroke-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property text-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!
- W: Unable to convert property text-color to type class java.awt.Color: found Keyword{lime-green} of type class org.openstreetmap.josm.gui.mappaint.Keyword!

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14862.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.