Modify

Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#14924 closed defect (fixed)

NPE while reading nmea file

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone: 17.06
Component: Core Version:
Keywords: template_report nmea Cc:

Description

What steps will reproduce the problem?

  1. Start josm with nmea file name on command line

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-06-10 19:26:28 +0200 (Sat, 10 Jun 2017)
Build-Date:2017-06-11 01:32:44
Revision:12389
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12389 en) Linux Debian GNU/Linux 9 (stretch)
Memory Usage: 540 MB / 2604 MB (309 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-2-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u131-b11-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
Program arguments: [log_ttyublox5_1496669022.nmea]

Plugins:
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ geochat (33088)
+ pbf (33241)
+ photo_geotagging (33088)
+ reltoolbox (33311)
+ reverter (33088)
+ utilsplugin2 (33328)

Map paint styles:
- https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Ph_Typhoon&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/sac_scale&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ShowID&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1

Last errors/warnings:
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (37) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.io.NmeaReader.parseNMEASentence(NmeaReader.java:326)
	at org.openstreetmap.josm.io.NmeaReader.<init>(NmeaReader.java:169)
	at org.openstreetmap.josm.io.NMEAImporter.importData(NMEAImporter.java:46)
	at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:92)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:355)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:308)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (10)

comment:1 Changed 4 months ago by bastiK

Does it work when you open via File > Open? Please attach the file.

comment:2 Changed 4 months ago by Don-vip

Keywords: nmea added
Milestone: 17.06

comment:3 Changed 3 months ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

comment:4 Changed 3 months ago by Don-vip

Owner: changed from anonymous to Don-vip
Status: needinfoassigned

Thanks to #14321 I have successfully identified and contacted the bug reporter. He won't attach his file here due to privacy concerns but I have asked him to send it to me privately in order to fix the bug.

Last edited 3 months ago by Don-vip (previous) (diff)

comment:5 Changed 3 months ago by Don-vip

Summary: error while reading nmea fileNPE while reading nmea file

comment:6 Changed 3 months ago by Don-vip

In 12421/josm:

see #14924 - improve NMEA documentation thanks to gpsd (http://www.catb.org/gpsd/NMEA.html) + add support for NMEA sentences coming from GLONASS, Galileo or Beidu receivers

comment:7 Changed 3 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 12422/josm:

fix #14924 - fix NPE when reading NMEA files starting with a (0,0) coordinate followed by a VTG sentence

comment:8 Changed 3 months ago by Don-vip

In 12423/josm:

see #14924 - support NMEA IN and EC talker IDs, found in gpsd test files, as they can be obtained from real maritime navigation systems / gps receivers

comment:9 Changed 3 months ago by Don-vip

In 12424/josm:

see #14924 - support NMEA GLL sentence

comment:10 Changed 3 months ago by Don-vip

In 12426/josm:

see #14924 - remove useless <CR><LF> from javadoc

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.