Modify

#14878 closed defect (duplicate)

JOSM should not download data into layers with upload=false

Reported by: AndrewBuck Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Currently when you have a layer with the upload=false (or upload=never) flag set on it if you download data from OSM without setting the 'download as new layer' checkbox josm will load the data into the upload=false layer.

This seems like a bug to me. Basically I think this should be treated like a layer merge which should either trigger a warning in the case of upload=false or automatically force a new layer in the case of upload=never.

Attachments (0)

Change History (1)

comment:1 Changed 13 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #8039.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.