Modify

Opened 2 years ago

Closed 2 years ago

#14822 closed defect (duplicate)

IllegalStateException at DataSetCommandMerger.getMergeTarget

Reported by: Kreuzschnabel Owned by: Upliner
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

Trying to revert CS #48841472 in JOSM and reverter plugin. After clicking Data → Revert changeset → Entire Changeset, the download progress bar pops up, then, without any action from my side, this error report comes up.

--ks

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-02 23:28:33 +0200 (Tue, 02 May 2017)
Build-Date:2017-05-02 21:34:40
Revision:12039
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12039 de) Linux Debian GNU/Linux 8.8 (jessie)
Memory Usage: 3360 MB / 3641 MB (2819 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-1~bpo8+1-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
Java package: openjdk-8-jre:amd64-8u131-b11-1~bpo8+1
Java ATK Wrapper package: libatk-wrapper-java:all-0.30.5-1
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (33182)
+ FastDraw (33182)
+ Mapillary (v1.5.3)
+ PicLayer (33148)
+ alignways (33182)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ continuosDownload (53)
+ contourmerge (1030)
+ download_along (32946)
+ livegps (33138)
+ measurement (33088)
+ reverter (33088)
+ terracer (33088)
+ undelete (33263)
+ utilsplugin2 (33212)

Tagging presets:
+ <josm.pref>/eigene-vorlagen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 3.246.114.485 nicht gefunden
- W: JOSM erwartet das Objekt [Punkt 3246114485] im Datensatz zu finden, aber es ist nicht vorhanden. Bitte melden Sie dies unter https://josm.openstreetmap.de. Es handelt sich nicht um einen kritischen Fehler. Sie sollten die Arbeit mit JOSM fortsetzen können.
- E: java.lang.Exception
- W: JOSM erwartet das Objekt [Punkt 3246114484] im Datensatz zu finden, aber es ist nicht vorhanden. Bitte melden Sie dies unter https://josm.openstreetmap.de. Es handelt sich nicht um einen kritischen Fehler. Sie sollten die Arbeit mit JOSM fortsetzen können.
- E: java.lang.Exception
- E: Handled by bug report queue: java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 3.246.114.485 nicht gefunden


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalStateException: Beim Zusammenführen wurde das Ziel-Objekt vom Type Punkt für das Objekt mit der Kennung 3.246.114.485 nicht gefunden
	at reverter.DataSetCommandMerger.getMergeTarget(DataSetCommandMerger.java:62)
	at reverter.DataSetCommandMerger.mergeNode(DataSetCommandMerger.java:82)
	at reverter.DataSetCommandMerger.merge(DataSetCommandMerger.java:173)
	at reverter.DataSetCommandMerger.<init>(DataSetCommandMerger.java:46)
	at reverter.ChangesetReverter.getCommands(ChangesetReverter.java:350)
	at reverter.RevertChangesetTask.realRun(RevertChangesetTask.java:112)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by Don-vip

Summary: CS Revert crashes repeatedlyIAE at DataSetCommandMerger.getMergeTarget

comment:2 Changed 2 years ago by Don-vip

Summary: IAE at DataSetCommandMerger.getMergeTargetIllegalStateException at DataSetCommandMerger.getMergeTarget

comment:3 Changed 2 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13981.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.