Modify

Opened 2 years ago

Closed 2 years ago

#14757 closed defect (fixed)

Attempt to use "Turn Lanes" plugin causes exception

Reported by: anonymous Owned by: benshu
Priority: normal Milestone:
Component: Plugin turnlanes Version: tested
Keywords: template_report Cc: hamish.blair@…

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Install "Turn Lanes" ("turnlanes") plugin (Not "turnlanes-tagging" and not "turnrestrictions")
  2. Let JOSM restart
  3. Click a junction (not sure if this is relevant)
  4. Open Windows menu
  5. Click "Turn Lanes"

What is the expected result?

Turn Lane windows should open

What happens instead?

"An unexpected exception occurred.
This is always a coding error. If you are running hte latest version of JOSM, please consider being kind and file a bug report.

Is JOSM up to date?

Your current version of JOSM is 12,039
JOSM is up to date."

Please provide any additional information below. Attach a screenshot if possible.

point at which turn lanes window failed to get created

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-02 23:28:33 +0200 (Tue, 02 May 2017)
Build-Date:2017-05-02 21:34:40
Revision:12039
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12039 en_GB) Windows 7 64-Bit
Memory Usage: 456 MB / 907 MB (246 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1680x1050
Maximum Screen Size: 1920x1080
Program arguments: [org.openstreetmap.josm.Main]
Dataset consistency test: No problems found

Plugins:
+ turnlanes (33088)

Last errors/warnings:
- W: extended font config - overriding 'allfonts.symbol=Symbol' with 'Segoe UI Symbol'
- E: Handled by bug report queue: sun.dc.pr.PRError: setDashT4: invalid dash transformation (singular)
- E: Handled by bug report queue: sun.dc.pr.PRError: setDashT4: invalid dash transformation (singular)


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
sun.dc.pr.PRError: setDashT4: invalid dash transformation (singular)
	at sun.dc.pr.PathDasher.setDashT4(Native Method)
	at sun.dc.pr.Rasterizer.setDashT4(Unknown Source)
	at sun.dc.DuctusRenderingEngine.getAATileGenerator(Unknown Source)
	at sun.java2d.pipe.AAShapePipe.renderPath(Unknown Source)
	at sun.java2d.pipe.AAShapePipe.draw(Unknown Source)
	at sun.java2d.pipe.PixelToParallelogramConverter.draw(Unknown Source)
	at sun.java2d.pipe.ValidatePipe.draw(Unknown Source)
	at sun.java2d.SunGraphics2D.draw(Unknown Source)
	at org.openstreetmap.josm.plugins.turnlanes.gui.RoadGui.paintLanes(RoadGui.java:735)
	at org.openstreetmap.josm.plugins.turnlanes.gui.RoadGui.paintLanes(RoadGui.java:666)
	at org.openstreetmap.josm.plugins.turnlanes.gui.RoadGui.paint(RoadGui.java:587)
	at org.openstreetmap.josm.plugins.turnlanes.gui.JunctionPane.paintPassive(JunctionPane.java:451)
	at org.openstreetmap.josm.plugins.turnlanes.gui.JunctionPane.paintComponent(JunctionPane.java:391)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at org.openstreetmap.josm.gui.widgets.MultiSplitPane.paintChildren(MultiSplitPane.java:206)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JSplitPane.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JLayeredPane.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

2017-05-08 turn lanes plugin fails.png (423.4 KB) - added by hamish.blair@… 2 years ago.
point at which turn lanes window failed to get created

Download all attachments as: .zip

Change History (6)

Changed 2 years ago by hamish.blair@…

point at which turn lanes window failed to get created

comment:1 Changed 2 years ago by Hamish Blair <hamish.blair@…>

Cc: hamish.blair@… added

comment:2 Changed 2 years ago by Hamish Blair <hamish.blair@…>

Restarted, in cygwin (java -jar josm-tested.jar), didn't click anything on the map, just opened Windows menu, then selected Turn Lanes, minimised other windows, couldn't find Turn Lanes window. Retried opening Windows menu, clicked Turn Lanes again, then window appeared.
Closed JOSM

Opened JOSM from Windows cmd: java -jar josm-tested.jar org.openstreetmap.josm.Main
Turn Lanes window was still open.

Exception must have been because I selected a junction before I opened the Turn Lanes window.

comment:3 Changed 2 years ago by Don-vip

Description: modified (diff)

comment:4 Changed 2 years ago by Don-vip

Thank you for very detailed bug report, I'm able to reproduce :)

Build-Date:2017-05-08 19:40:56
Revision:12086
Is-Local-Build:true

Identification: JOSM/1.5 (12086 SVN en) Windows 10 64-Bit
Memory Usage: 1049 MB / 3634 MB (912 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1920x1080, \Display2 1280x1024
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ turnlanes (33088)

Last errors/warnings:
- E: Handled by bug report queue: sun.dc.pr.PRError: setDashT4: invalid dash transformation (singular)
- E: Handled by bug report queue: sun.dc.pr.PRError: setDashT4: invalid dash transformation (singular)

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (23) of main
sun.dc.pr.PRError: setDashT4: invalid dash transformation (singular)
	at sun.dc.pr.PathDasher.setDashT4(Native Method)
	at sun.dc.pr.Rasterizer.setDashT4(Rasterizer.java:386)
	at sun.dc.DuctusRenderingEngine.getAATileGenerator(DuctusRenderingEngine.java:422)
	at sun.java2d.pipe.AAShapePipe.renderPath(AAShapePipe.java:152)
	at sun.java2d.pipe.AAShapePipe.draw(AAShapePipe.java:64)
	at sun.java2d.pipe.PixelToParallelogramConverter.draw(PixelToParallelogramConverter.java:148)
	at sun.java2d.pipe.ValidatePipe.draw(ValidatePipe.java:154)
	at sun.java2d.SunGraphics2D.draw(SunGraphics2D.java:2497)
	at org.openstreetmap.josm.plugins.turnlanes.gui.RoadGui.paintLanes(RoadGui.java:735)
	at org.openstreetmap.josm.plugins.turnlanes.gui.RoadGui.paintLanes(RoadGui.java:659)
	at org.openstreetmap.josm.plugins.turnlanes.gui.RoadGui.paint(RoadGui.java:587)
	at org.openstreetmap.josm.plugins.turnlanes.gui.JunctionPane.paintPassive(JunctionPane.java:451)
	at org.openstreetmap.josm.plugins.turnlanes.gui.JunctionPane.paintComponent(JunctionPane.java:391)
...
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

comment:5 Changed 2 years ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33294:33295].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain benshu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.