Modify

Opened 4 years ago

Closed 4 months ago

Last modified 3 months ago

#14741 closed defect (worksforme)

Application is called "MainApplication" in the MacOS menu bar, instead of JOSM

Reported by: Polarbear-j Owned by: Polarbear-j
Priority: normal Milestone: 20.11
Component: Core Version:
Keywords: MacOS regression Cc: Stereo, michael2402

Description

Since some update in April, JOSM presents itself as "MainApplication" in the MacOS menu bar.

Identification: JOSM/1.5 (12060 en) Mac OS X 10.11.6
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Attachments (2)

14741_worksforme.png (248.7 KB) - added by Don-vip 4 years ago.
josm-mainapp.png (81.2 KB) - added by Polarbear-j 4 years ago.

Download all attachments as: .zip

Change History (38)

comment:1 Changed 4 years ago by bastiK

Result of [11926]?

comment:2 Changed 4 years ago by Polarbear-j

Plausibly, my 'previous' version where I first observed this, is indeed
Build-Date:2017-04-16 01:33:16
Revision:11926
Identification: JOSM/1.5 (11926 en) Mac OS X 10.11.6

comment:3 Changed 4 years ago by Don-vip

Component: CoreInstaller MacOS
Keywords: regression added
Milestone: 17.05
Owner: changed from team to Don-vip
Priority: minornormal
Status: newassigned

Changed 4 years ago by Don-vip

Attachment: 14741_worksforme.png added

comment:4 Changed 4 years ago by Don-vip

Works for me with Sierra and Java 8u131:


Can you please:

  1. upgrade your version of Java
  2. if the problem still occurs, post your status report and a screenshot
  3. see if the problem disappears by upgrading to Sierra

comment:5 Changed 4 years ago by Don-vip

Owner: changed from Don-vip to Polarbear-j
Status: assignedneedinfo

comment:6 Changed 4 years ago by Don-vip

Milestone: 17.05

Changed 4 years ago by Polarbear-j

Attachment: josm-mainapp.png added

comment:7 Changed 4 years ago by Polarbear-j


Did upgrade now Java -> 1.8.0_131 and JOSM -> today
Still running MacOS 10.11.6, will not change a major system release on my production system just for a decorative issue.
This should work in 10.11 as well as it is still supported by Apple.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-08 22:03:16 +0200 (Mon, 08 May 2017)
Build-Date:2017-05-09 01:33:49
Revision:12090
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12090 en) Mac OS X 10.11.6
Memory Usage: 644 MB / 3641 MB (154 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69733312 2048x1280, Display 725111823 1680x1050
Maximum Screen Size: 2048x1280

Plugins:
+ FastDraw (33182)
+ HouseNumberTaggingTool (33160)
+ InfoMode (33004)
+ Mapillary (v1.5.3)
+ PicLayer (33148)
+ RoadSigns (33204)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ jogl (1.0.46)
+ kendzi3d (1.0.195)
+ kendzi3d-resources (0.0.1)
+ lakewalker (33161)
+ log4j (32699)
+ measurement (33088)
+ print (33260)
+ reverter (33088)
+ tageditor (33021)
+ terracer (33088)
+ turnlanes-tagging (254)
+ turnrestrictions (33088)
+ undelete (33263)
+ utilsplugin2 (33297)
+ waydownloader (33167)
+ wikipedia (33288)

comment:8 Changed 4 years ago by Don-vip

Cc: Stereo added

@Stereo: can you please tell me if you face the same problem with Sierra?

If the problem is specific to an old version of macOs I won't fix it. Apple supports it, but we don't.

comment:9 Changed 4 years ago by Stereo

I can't reproduce it on 10.12.4 either. Strange bug!

comment:10 Changed 4 years ago by Don-vip

Resolution: othersoftware
Status: needinfoclosed

OK seems to be an old macOs bug then.

comment:11 Changed 4 years ago by Polarbear-j

Since it is a decorative issue, I am not crying too loud here.
However it worked before in my very same MacOS release, and the first response by bastiK pointed to a changeset where exactly this label was removed.

comment:12 Changed 4 years ago by stoecker

Resolution: othersoftware
Status: closedreopened

I'd suggest to revert that change. Costs are minimal.

comment:13 Changed 4 years ago by Don-vip

@Polarbear-j: are you at least using the OSX package? Have you tried with WebStart?

comment:14 Changed 4 years ago by anonymous

Ah, tried josm-macosx.zip --> JOSM.app
Build-Date:2017-05-02 21:34:40
Identification: JOSM/1.5 (12039 en) Mac OS X 10.11.6
which correctly displays 'JOSM'. Which apparently comes from the Info.plist in the packacke, I can hack other names into this.

However it seems only the stable versions are packaged, and calling as an app I don't see the terminal output which I occasionally need to check (does that go elsewhere?)

Normally I get the josm-latest.jar from the server and call it from the terminal.

comment:15 Changed 4 years ago by Don-vip

Milestone: 17.05

OK I didn't get you were launching the jar from command line, very few people on macOS do that.

comment:16 Changed 4 years ago by Don-vip

In 12123/josm:

see #14741 - proper registration of application name on macOS

comment:17 Changed 4 years ago by Don-vip

Cc: michael2402 added

@Michael: I need your help here.

I have registered the macOS application name in the proper way in r12123 but it does not work yet because JOSM loads AWT/Swing classes before PlatformHook.preStartupHook, which shouldn't be.

The root cause if the initialisation of Main.mainPanel:

    /**
     * The real main panel. This field may be removed any time and made private to {@link MainFrame}
     * @see #panel
     */
    protected static final MainPanel mainPanel = new MainPanel(getLayerManager());

I totally agree with the comment, is it something you started to implement? I'd really like to see this field disappear from Main to fix this ticket.

Last edited 4 years ago by Don-vip (previous) (diff)

comment:18 Changed 4 years ago by Don-vip

Component: Installer MacOSCore

comment:19 Changed 4 years ago by Don-vip

By the way, isn't it a big EDT violation to initialize a JPanel here?

comment:20 Changed 4 years ago by michael2402

I have no Idea how MacOS handles this naming...

We have an EDT violation here, but it does not cause problems since we are calling it before main() even starts and before we do anything else using swing.

The reason I moved it there was that I had dependency problems (Main.panel). It would be good to move the initialization to somewhere later.
If there are no dependencies on Main.panel being the main panel any more, we can even move this initialization to the end of the startup process (UI construction). I don't know if it will cause problems with plugins, there are so many references to Main.panel that I did not check them all.

comment:21 Changed 4 years ago by Don-vip

OK thanks, I check how to sort this issue.

comment:22 Changed 4 years ago by Don-vip

In 12125/josm:

see #14741 - rework initialization of Main.Panel so that it is done after PlatformHook.preStartupHook, as any other Swing code

comment:23 Changed 4 years ago by naoliv

I guess that [12125] caused #14783

comment:24 Changed 4 years ago by Don-vip

In 12128/josm:

see #14741 - rework initialization of Main.contentPanePrivate

comment:25 Changed 4 years ago by Don-vip

Resolution: fixed
Status: reopenedclosed

ok it works now :)

comment:26 Changed 4 years ago by Don-vip

In 12133/josm:

see #14741 - findbugs

comment:27 Changed 4 years ago by Polarbear-j

yeah, thanks :-) (12133)

comment:28 Changed 3 years ago by Polarbear-j

Resolution: fixed
Status: closedreopened

The issue is back for me.

Identification: JOSM/1.5 (12991 en) Mac OS X 10.11.6
OS Build number: Mac OS X 10.11.6 (15G1611)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

It worked correctly with the previous version I downloaded on 20 August.

comment:29 Changed 8 months ago by Stereo

Hi Polarbear! Can you please see if the issue is fixed in https://openstreetmap.lu/JOSM.zip ?

comment:30 Changed 8 months ago by anonymous

Hm, I did not pay attention recently what was showing up and when.
Anyway I typically use the josm-latest.jar and call it from the terminal, not the app.
Meanwhile I'm running macos 10.14.6 and the JOSM title shows correctly in:

Identification: JOSM/1.5 (16511 en) Mac OS X 10.14.6
OS Build number: Mac OS X 10.14.6 (18G5033)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

I'm a bit reluctant to try the app version from the zip file in parallel,
unless I know if it uses the same or different folders for prefs, plugins an caches?

comment:31 in reply to:  30 Changed 8 months ago by Polarbear-j

Replying to anonymous:
reply above was mine.

comment:32 Changed 8 months ago by Stereo

Yeah, that'll be fine. It might, in the worst case, upgrade some plugins, but if you want to go back to java -jar and the old version, and they're incompatible, you could uninstall and reinstall them.

I've been using that way of building the .app as my "daily" JOSM for the last couple of weeks.

That .app also supports retina resolution, which is great for imagery, and the http/2 plugin, which makes imagery faster.

comment:33 Changed 5 months ago by Stereo

Status: reopenedneedinfo

Please try the latest pre-release at https://github.com/thomersch/josm/releases and see if you can still reproduce this?

comment:34 Changed 4 months ago by Stereo

Milestone: 17.0520.10
Resolution: worksforme
Status: needinfoclosed

I can't reproduce this in the latest builds at https://github.com/openstreetmap/josm/releases

Last edited 4 months ago by Stereo (previous) (diff)

comment:35 Changed 4 months ago by Polarbear-j

Ok so eventually I tested the JOSM.app from github as asked for, after backing up my prefs file.
First attempt got a MacOS complaint that the app was 'defective' and I should trash it.
I didn't, instead I removed the quarantine flags, and it started smoothly.
I could reproduce the behaviour with the quarantine flag when unpacking the zip file a second time.

So far the .app worked fine, does display 'JOSM' in the menu bar, and did not eat any of my jelly bears.

I wonder if I need to see any retina-related difference compared to the .jar file downloaded from https://josm.openstreetmap.de,
in particular since that had a facelift with new icons recently anyway?

In the status report however I see that the .app reports "scaling 2.0x2.0" on the retina screen, while the .jar reports "scaling 1.0x1.0". See below.

===

Revision:17306
Is-Local-Build:true
Build-Date:2020-11-09 10:27:17

Identification: JOSM/1.5 (17306 SVN en_GB) Mac OS X 10.14.6
OS Build number: Mac OS X 10.14.6 (18G6032)
Memory Usage: 336 MB / 8192 MB (105 MB allocated, but free)
Java version: 15.0.1+8, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733248 1920x1200 (scaling 2.0x2.0), Display 724051919 1920x1200 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1200
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [--module-path=/Volumes/homes/Shared/bin/josm/JOSM.app/Contents/app/mods]
Dataset consistency test: No problems found

====

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-03 00:09:37 +0100 (Tue, 03 Nov 2020)
Build-Date:2020-11-03 02:30:51
Revision:17292
Relative:URL: /trunk

Identification: JOSM/1.5 (17292 en_GB) Mac OS X 10.14.6
OS Build number: Mac OS X 10.14.6 (18G6032)
Memory Usage: 1706 MB / 3641 MB (1449 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733248 1920x1200 (scaling 1.0x1.0), Display 724051919 1920x1200 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1200
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Dataset consistency test: No problems found

comment:36 Changed 3 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Polarbear-j.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.