Modify

Opened 20 months ago

Closed 19 months ago

Last modified 19 months ago

#14737 closed defect (fixed)

Order is not preserved when selecting multiple items

Reported by: ShadowFoxNixill Owned by: team
Priority: normal Milestone: 17.05
Component: Core Version:
Keywords: template_report selection regression Cc: michael2402

Description (last modified by ShadowFoxNixill)

What steps will reproduce the problem?

  1. Create a new relation, or view an existing one.
  2. Select a few things, for example a series of connected ways (in order from end to end).
  3. Add them to the relation.

What is the expected result?

The ways would be in order, and all connected

What happens instead?

The ways are jumbled in an arbitrarily determined order.

Please provide any additional information below. Attach a screenshot if possible.

Screenshot after selection: http://prntscr.com/f49h1l

Screenshot with expected order: http://prntscr.com/f49h75

It's worth noting that the Sort button will work if you are trying to add a series of connected ways (with some side effects, like http://prntscr.com/f49hse instead of http://prntscr.com/f49huy), but it won't work if the items you're trying to sort aren't connected ways (for example, an ordered sequence of bus stops).

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-03 22:19:58 +0200 (Wed, 03 May 2017)
Build-Date:2017-05-04 01:33:16
Revision:12057
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12057 en) Windows 10 64-Bit
Memory Usage: 242 MB / 247 MB (108 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080, \Display1 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\31\583aa85f-330a2f35, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=51685, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm-latest.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe]
Dataset consistency test: No problems found

Plugins:
+ apache-commons (32994)
+ ejml (32680)
+ geotools (33042)
+ jts (32699)
+ opendata (33245)
+ turnrestrictions (33088)
+ utilsplugin2 (33212)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1

Map paint styles:
+ https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
+ %UserProfile%\GoogleDrive\JOSM\publictransport.mapcss

Last errors/warnings:
- W: extended font config - overriding 'allfonts.symbol=Symbol' with 'Segoe UI Symbol'

Attachments (0)

Change History (6)

comment:1 Changed 20 months ago by ShadowFoxNixill

Description: modified (diff)

(Removed something that should have been a comment instead - "Major priority as it affects the creation/alteration of any type of Route relation.")

comment:2 Changed 20 months ago by michael2402

Cc: michael2402 added
Keywords: selection added
Priority: majornormal
Type: defectenhancement

It was never intended for the relation to be sorted by the order the relation members were selected. But this might be a good enhancement.

An alternative of this would be to add a sorted button to the relation editor, that sorts the ways before adding them.

comment:3 Changed 20 months ago by ShadowFoxNixill

Past versions of JOSM have retained order of selection properly, and it only broke within the last couple of days. That's why I marked it as a defect.

comment:4 Changed 20 months ago by michael2402

Type: enhancementdefect

OK, I'll have a look at it. I never noticed that.

comment:5 Changed 19 months ago by michael2402

Resolution: fixed
Status: newclosed

In 12069/josm:

Fix #14737: Preserve selection order and add comments that it is ordered. Add unit tests.

comment:6 Changed 19 months ago by michael2402

Keywords: regression added
Milestone: 17.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.