Modify

Opened 4 years ago

Closed 4 years ago

#14731 closed defect (duplicate)

addres2

Reported by: gy9vin@… Owned by: Hind
Priority: normal Milestone:
Component: Plugin commandline Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-03 00:00:50 +0200 (Wed, 03 May 2017)
Build-Date:2017-05-03 01:33:43
Revision:12040
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12040 ru) Windows 10 64-Bit
Memory Usage: 15701 MB / 15701 MB (15022 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ CommandLine (33239)
+ buildings_tools (33004)

Last errors/warnings:
- W: extended font config - overriding 'allfonts.symbol=Symbol' with 'Segoe UI Symbol'
- W: org.openstreetmap.josm.io.IllegalDataException: Строка 1 столбец 1: Premature end of file.. Причина: org.xml.sax.SAXParseException: Premature end of file.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener CommandLine.PointAction@2cba8186 (instance of CommandLine.PointAction) was not registered before or already removed.
- W: org.openstreetmap.josm.io.IllegalDataException: Строка 1 столбец 1: Premature end of file.. Причина: org.xml.sax.SAXParseException: Premature end of file.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener CommandLine.PointAction@71930bae (instance of CommandLine.PointAction) was not registered before or already removed.
- W: org.openstreetmap.josm.io.IllegalDataException: Строка 1 столбец 1: Premature end of file.. Причина: org.xml.sax.SAXParseException: Premature end of file.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener CommandLine.PointAction@36ac472b (instance of CommandLine.PointAction) was not registered before or already removed.
- W: org.openstreetmap.josm.io.IllegalDataException: Строка 1 столбец 1: Premature end of file.. Причина: org.xml.sax.SAXParseException: Premature end of file.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener CommandLine.PointAction@2421ca32 (instance of CommandLine.PointAction) was not registered before or already removed.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (28) of main
java.lang.IllegalArgumentException: Listener CommandLine.PointAction@2421ca32 (instance of CommandLine.PointAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:134)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:211)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:128)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:195)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:249)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:110)
	at CommandLine.PointAction.exitMode(PointAction.java:62)
	at CommandLine.PointAction.mousePressed(PointAction.java:93)
	at java.awt.AWTEventMulticaster.mousePressed(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin commandline
Owner: changed from team to Hind

comment:2 Changed 4 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13631.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Hind.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.