Modify

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#14685 closed defect (fixed)

presets_lang.pl gets in trouble with switch and switchgear

Reported by: Klumbumbus Owned by: team
Priority: normal Milestone: 17.04
Component: Core Version:
Keywords: script Cc: stoecker

Description

executing presets_lang.pl replaces the links of power=switchgear by power=switch which can be seen in r11989. It happens to me too, when I execute the script. Also it doesn't correctly update power=switch. r11980 was added manually and was not added by the script in r11979.

Attachments (0)

Change History (4)

comment:1 Changed 22 months ago by stoecker

Resolution: fixed
Status: newclosed

In 11994/josm:

fix #14685 - wiki language link extractor fails for URL's with equal beginning, drop old workaround

comment:2 Changed 22 months ago by Don-vip

I don't understand the root cause neither the fix. Can you please enlighten me? :)

comment:3 Changed 22 months ago by Don-vip

Milestone: 17.04

comment:4 in reply to:  2 Changed 22 months ago by stoecker

Replying to Don-vip:

I don't understand the root cause neither the fix. Can you please enlighten me? :)

Hmm, a single character change should be easy understandable. :-)

The URL for switchgear and switch is identical except for the last 4 characters appended. As the replace simply replaced the first occurrence, the "switch" URL replaced the switchgear instead. Adding the " sign prevents this.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.