Modify

Opened 4 years ago

Closed 4 years ago

#14555 closed defect (fixed)

"Lane and road attributes" style incorrectly displays the lanes

Reported by: sznik Owned by: team
Priority: normal Milestone:
Component: External mappaint style Version:
Keywords: template_report Cc: imagic

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

  1. Load and display "Lane and road attributes" style
  2. Draw way from down to up and set tags: highway=residential lanes=3 lanes:forward=2 lanes:backward=1 turn:lanes:forward=none|right

What is the expected result?

Right turn arrow is displayed on the right lane.
Double dotted line appears is displayed between the first and the second lane.

What happens instead?

Right turn arrow is displayed on the middle lane
Double dotted line appears is displayed between the second and the third lane.


URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-26 23:10:22 +0100 (Sun, 26 Feb 2017)
Build-Date:2017-02-26 22:34:39
Revision:11639
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11639 pl) Windows 7 64-Bit
Memory Usage: 192 MB / 494 MB (99 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ CommandLine (33026)
+ DirectUpload (32885)
+ InfoMode (33004)
+ OpeningHoursEditor (33004)
+ RoadSigns (33088)
+ alignways (33136)
+ buildings_tools (33004)
+ contourmerge (1030)
+ download_along (32946)
+ editgpx (33004)
+ ext_tools (33004)
+ imagery_offset_db (33004)
+ jna (32699)
+ log4j (32699)
+ measurement (33088)
+ merge-overlap (33154)
+ openvisible (33088)
+ reverter (33088)
+ terracer (33088)
+ turnrestrictions (33088)
+ utilsplugin2 (33124)
+ waypoint_search (32699)

Tagging presets:
+ http://osmtools.de/josm/steps.xml
+ https://raw.github.com/przemas75/OSM-permissions-preset/master/Presets_access_PL-preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
+ https://raw.githubusercontent.com/zibik/stork_nests/master/stork_preset.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/maxspeed_PL&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1

Attachments (3)

Capture1.PNG (48.4 KB) - added by sznik 4 years ago.
x.osm (556 bytes) - added by sznik 4 years ago.
"Way" in Wroclaw, Poland
laneandroads.png (18.7 KB) - added by Klumbumbus 4 years ago.

Download all attachments as: .zip

Change History (14)

Changed 4 years ago by sznik

Attachment: Capture1.PNG added

comment:1 Changed 4 years ago by bastiK

On Styles/Lane_and_Road_Attributes it says "To report bugs or provide feedback send me a message."

Could you do that?

comment:2 Changed 4 years ago by Klumbumbus

Looks like you are in an area with left hand traffic.

comment:3 in reply to:  2 Changed 4 years ago by anonymous

Replying to Klumbumbus:

Looks like you are in an area with left hand traffic.

How to switch to right hand traffic?
I edit map in Poland not UK :)
I don't send feedback to Imagic because recently the style has been changed 22 months ago.

comment:4 in reply to:  2 ; Changed 4 years ago by sznik

Replying to Klumbumbus:

Looks like you are in an area with left hand traffic.

How to switch to right hand traffic?
I edit map in Poland not UK :)
I don't send feedback to Imagic because recently the style has been changed 22 months ago.

comment:5 Changed 4 years ago by Klumbumbus

Description: modified (diff)

comment:6 in reply to:  4 ; Changed 4 years ago by Klumbumbus

Replying to sznik:

Replying to Klumbumbus:

Looks like you are in an area with left hand traffic.

How to switch to right hand traffic?

It's automatic as long as the color mappaint lane: and.road.attributes.boolean.right.hand.traffic in your josm color preferences is NOT black or white. Please check this.
Please also double check if you are editing in an area with right hand traffic.

Changed 4 years ago by sznik

Attachment: x.osm added

"Way" in Wroclaw, Poland

comment:7 in reply to:  6 Changed 4 years ago by sznik

Replying to Klumbumbus:
In my JOSM color.mappaint.lane.and.road.attributes.boolean.right.hand.traffic = #888888
I add new attachment "x.osm" with "way" in Poland.
Could you check if the way is displayed correctly?

comment:8 Changed 4 years ago by Klumbumbus

Yes it is displayed correctly for me. see attached screenshot.

Changed 4 years ago by Klumbumbus

Attachment: laneandroads.png added

comment:9 Changed 4 years ago by Klumbumbus

Cc: imagic added

comment:10 in reply to:  8 Changed 4 years ago by sznik

Replying to Klumbumbus:

Yes it is displayed correctly for me. see attached screenshot.

I deleted cache and now it's ok.

comment:11 Changed 4 years ago by sznik

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.