Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1455 closed enhancement (fixed)

[PATCH] keyboard shortcut for changing display of gps tracks (points--lines)

Reported by: Schusch Owned by: Henry Loenwind
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

It would make the use of josm even better, if it would be possible to change the display of the gps points on the fly.

If I change this now (doing so in the preferences), I have to restart josm if I want to use yahoo aerial images (menu WMS is deactivated after changing preferences).

So two proposals here

  • changing a preference like displaying the gps tracks in another way shouldn't deactivate WMS services (that's the more important one)
  • a keyboard shortcut for changing the gps track display would be fine

(and a big thanks for the space :-)

Schusch

Attachments (4)

ToggleGPXLinesAction.java (813 bytes) - added by Henry Loenwind 14 years ago.
MainMenu.diff (830 bytes) - added by Henry Loenwind 14 years ago.
empty_24px.png (229 bytes) - added by Henry Loenwind 14 years ago.
empty_16px.png (216 bytes) - added by Henry Loenwind 14 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 14 years ago by anonymous

Duplicate of #814.

comment:2 Changed 14 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:3 Changed 14 years ago by Schusch

Resolution: duplicate
Status: closedreopened
Summary: changing display of gps tracks should not deactivate wms services (+shortcut for this)keyboard shortcaut for changing display of gps tracks (points--lines)

is it ok, if I change the title a bit and just focus on the keyboard shortcut?

I couldn't find a possibility to change the view between points and lines without going through the preferences dialog. I change this view quite often to interpret my gps tracks.

greetings, Schusch

comment:4 Changed 14 years ago by anonymous

Summary: keyboard shortcaut for changing display of gps tracks (points--lines)keyboard shortcut for changing display of gps tracks (points--lines)

corr. title

comment:5 Changed 14 years ago by anonymous

Status: reopenednew

comment:6 Changed 14 years ago by Henry Loenwind

Owner: changed from framm to Henry Loenwind

As I'm working on keyboard shortcuts atm, I'll put this on my list.

Anyone to volunteer an icon for this action?

comment:7 Changed 14 years ago by Henry Loenwind

Here is the patch. (Note: it depends on #1622)

You will find the new action "Toggle GPX lines" in the toolbar configuration. Once you have put it into the toolbar, its shortcut will be active. The shortcut is configurable, see the new shortcut configuration tab in the preferences window.

Changed 14 years ago by Henry Loenwind

Attachment: ToggleGPXLinesAction.java added

Changed 14 years ago by Henry Loenwind

Attachment: MainMenu.diff added

Changed 14 years ago by Henry Loenwind

Attachment: empty_24px.png added

Changed 14 years ago by Henry Loenwind

Attachment: empty_16px.png added

comment:8 Changed 14 years ago by Henry Loenwind

Summary: keyboard shortcut for changing display of gps tracks (points--lines)[PATCH] keyboard shortcut for changing display of gps tracks (points--lines)

comment:9 Changed 14 years ago by anonymous

Resolution: fixed
Status: newclosed

Applied (with changed image) in 1030.

comment:10 Changed 14 years ago by Schusch

hey :-) great ... thanks!

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Henry Loenwind.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.